Welcome to Geeklog Sunday, September 15 2019 @ 08:06 pm EDT

Geeklog Forums

Configuring paths in Windows 2000


Endimion

Anonymous

Hi! I'm rather new at this so please be nice.

I'm using the geeklog-1.3b3.tar.gz version and I've tried the install.php on a Windows 2000 machine (Apache, PHP and MySQL) well all was ok, it ask for the Geeklog path (Geeklog Path: C:wwwrootleo) but then it shows another long form with a lot of paths. and all of them are in "Unix flavor" for example:

Path to system directory: C:wwwrootleo/system/

Some of them can be changed, the others are fixed, if I change all the slashes to the Windows way show thisFrownafter the DB config)

Parse error: parse error in C:wwwrootleoconfig.php on line 89 Template Error: set_root: install_templates is not a directory. Halted.

What's going on? Is this thing just for Unix systems??

And please don't go berserk 'cause I'm using Windows... I know it sucks..

Thanks


Status: offline

Tony

Site Admin
Admin
Registered: 17/12/01
Posts: 405
Location:Urbandale, Iowa
First, I'd download the latest CVS version as it is the most recent. I have been developing Geeklog primarily on RH 7.2 (linux) and until this week I haven't tested much in Windows. When go to start to a fresh installation, make sure that the file config.php does not pre-exist. Otherwise the installation script will try using those entries as default values on the server settings installation page. (in otherwords, if config.php exists then delete it). Then take your browser to: http://url_to_my_geeklog/admin/install/install.php For your path enter something like c:\path\to\my\geeklog (notice the lack of an ending '\') when you hit next, your form *should* pre-fill all the paths with the paths you entered on the previous page...it least it did on my Win2kPro/Apache install. Then you will need to go into most all the files and remove the whitespace after each ?> as that will cause you some problems more than likely. I do have Geeklog working on windows...it will always work on windows (though it is a pain sometimes).
The reason people blame things on previous generations is that there's only one other choice.

Anonymous

Anonymous
Nope. I have the same problem. Followed your advice - no config.php file existing. There are still a few paths that you cannot change (have a / rather than \) and get the same parse error as stated above. Any other clues?

Status: offline

Tony

Site Admin
Admin
Registered: 17/12/01
Posts: 405
Location:Urbandale, Iowa
Well, I guess I'll just have to make the install script smart enough to use the right '/' when building the paths then.
The reason people blame things on previous generations is that there's only one other choice.

Anonymous

Anonymous
You did - found out if you don't mess with the paths (like you say in the install program but I didn't listen) then all works well. Nice job - my mistake! Now if I can just figure out why I get a "Warning: Cannot add header information - headers already sent by..." message when I access the first page. I ead past posts on this, eliminated any extra spaces in the lib file, but I still get it.

All times are EDT. The time is now 08:06 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content