Welcome to Geeklog Tuesday, March 19 2019 @ 05:50 am EDT

Geeklog Forums

File Management Plugin problems pls help!


munky

Anonymous
confused
Hi I have installed the filemgmt plugin on my virtual hosting. After slowly fishing through the errors trying to change the config (777 on php files etc. etc. sneaky ) I have one problem I cannot work around. When uploading the file, a variable $tmp defines where the file is uploaded to before it is written to the ../filemgmt_data/files/tmp dir for approval (I guess?). The error is thrown by files not being allowed (set by ISP, not me) to be copied from ../tmp server var to my hosting path. Can anyone tell me how I can change the $tmp var to a dir within my hosting access? Help is very welcome! Thanks.

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
Sounds like a permission setting on the filemgmt_data folders??

Mind if I add my errors here as well?

When I go to the Configuration Settings and attempt to change the paths, I get this error when saving changes:

Warning: fopen(/home/ainurcc/public_html/Trig/plugins/filemgmt/filemgmt.php): failed to open stream: Permission denied in /home/ainurcc/public_html/Trig/admin/plugins/filemgmt/index.php on line 1195

Warning: fwrite(): supplied argument is not a valid stream resource in /home/ainurcc/public_html/Trig/admin/plugins/filemgmt/index.php on line 1221

Warning: fclose(): supplied argument is not a valid stream resource in /home/ainurcc/public_html/Trig/admin/plugins/filemgmt/index.php on line 1222

Warning: Cannot modify header information - headers already sent by (output started at /home/ainurcc/public_html/Trig/admin/plugins/filemgmt/index.php:1195) in /home/ainurcc/public_html/Trig/lib-common.php(973) : eval()'d code on line 1

Any help is greatly appreciated. I have exhausted both forums and documents.

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
Seems our problems are serious

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
I guessed the above errors were caused by permissions so I set the permissions to 777 on any file or folder that had anything to do with the upload. I now get this message:

Warning: move_uploaded_file(g:/home/ainurcc/public_html/filemgmt_data/files/tmp/ygkVgZYilc.fxr): failed to open stream: No such file or directory in /home/ainurcc/public_html/Trig/filemgmt/submit.php on line 118

Warning: move_uploaded_file(): Unable to move '/tmp/phpazepVJ' to 'g:/home/ainurcc/public_html/filemgmt_data/files/tmp/ygkVgZYilc.fxr' in /home/ainurcc/public_html/Trig/filemgmt/submit.php on line 118

Warning: Cannot modify header information - headers already sent by (output started at /home/ainurcc/public_html/Trig/filemgmt/submit.php:11 in /home/ainurcc/public_html/Trig/lib-common.php(973) : eval()'d code on line 1

I am wondering if it is the path. If the filemgmnt folder is here:
www.ainurcc.com/filemgmt_data/files

Then in the configuration should it be this?:
"/home/ainucc/public_html/filemgmt_data/files/"

Status: offline

Vapour71

Forum User
Chatty
Registered: 10/02/05
Posts: 55
Location:Great White North Eh!
I ran into this issue a while back when installing this plugin. If I can remember correctly, you need to make sure that the filemgmt_data directory is in your public_html directory. Secondly, you also have to make sure you have the following sub-directories in your filemgmt_data directory:
PHP Formatted Code

o        filemgmt_data

o        filemgmt_data/files

o        filemgmt_data/files/tmp

o        filemgmt_data/snaps

o        filemgmt_data/snaps/tmp

o        filemgmt_data/category_snaps

 

Once that is done you have to set the permissions to those directories to 754. Hope this helps.
I've Gone To Find Myself. If I Show Up Before I Return, Make Me Wait Here Until I Get Back.

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
Thank you Vapour. I had missed the tmp folder when setting permissions. I also had my site name mispelled in the path. That was something I could not see in the error but did catch when reviewing the config panel. It works very nicely now!

Status: offline

Vapour71

Forum User
Chatty
Registered: 10/02/05
Posts: 55
Location:Great White North Eh!
Glad I was able to help you out. Sometimes we forget to check and double check certain things and sometimes the error logs can be a bit deceiving, leaving us looking for a hammer
I've Gone To Find Myself. If I Show Up Before I Return, Make Me Wait Here Until I Get Back.

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
Well, I thought it was working nicely. It uploaded the file but when I went to approve it, it couldnt find it. The paths were correct, but the temp names were not. I noticed I had 2 filemgmnt.php files. I deleted the one that was in admin/plugins/filemgmnt/adim and left the one that was in filemgmt/ where the config file is as well. I still get the same errors but at least now my config panel shows the correct data and saves it as well. The path is /home/ainurcc/public_html/filemgmt_data/ and the file seems to upload properly but then it simply doesnt exist when you go to approve it. When I hover over the Download to Preview button, I see a path similar to this: http://www.ainurcc.com/filemgmt_data/files/tmp/Gtb6Yhg.gif When I look on my server in that location, there is nothing. Here is a copy of my filemgmt.php file. Does it look correct???

$mydownloads_popular = 20;
$mydownloads_newdownloads = 10;
$mydownloads_perpage = 10;
$mydownloads_trimdesc = 1;
$mydownloads_whatsnew = 1;
$mydownloads_dlreport = 1;
$mydownloads_selectpriv = 1;
$mydownloads_publicpriv = 1;
$mydownloads_uploadselect = 1;
$mydownloads_uploadpublic = 0;
$mydownloads_useshots = 1;
$mydownloads_shotwidth = 50;
$filemgmt_Emailoption = 1;
$filemgmt_FileStore = "/home/ainurcc/public_html/filemgmt_data/files/";
$filemgmt_SnapStore = "/home/ainurcc/public_html/filemgmt_data/snaps/";
$filemgmt_SnapCat = "/home/ainurcc/public_html/filemgmt_data/category_snaps/";
$filemgmt_FileStoreURL = "http://www.ainurcc.com/filemgmt_data/files/";
$filemgmt_FileSnapURL = "http://www.ainurcc.com/filemgmt_data/snaps/";
$filemgmt_SnapCatURL = "http://www.ainurcc.com/filemgmt_data/category_snaps/";

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
If this thread was in the Plugin Help forum would it get more attention??

Status: offline

Vapour71

Forum User
Chatty
Registered: 10/02/05
Posts: 55
Location:Great White North Eh!
I don't have any files in any of my temp directories either however, where do you have all of your files located for your filemgmt? You Should have .
public_dir/admin/plugins/filemgmt
public_dir/filemgmt
public_dir/filemgmt_data (with all sub-directories)
public_dir/plugins/filemgmt

What filemgmt files do you have in those files except for your downloadable files for your users?


I've Gone To Find Myself. If I Show Up Before I Return, Make Me Wait Here Until I Get Back.

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
When I go to the Configuration Settings and attempt to change the paths, I get this error when saving changes:

Warning: fopen(/home/ainurcc/public_html/Trig/plugins/filemgmt/filemgmt.php): failed to open stream: Permission denied in /home/ainurcc/public_html/Trig/admin/plugins/filemgmt/index.php on line 1195

There is a little awkward issue with configuration. You have to set the permission of the above mentioned filemgmt.php to 777 before setting the configuration. The configuration is writing on this file. After you change the configuration, you can change the permission back to 644.

Without that none of your changes would take effect.

Hope this helps.

Sam

Status: offline

Vapour71

Forum User
Chatty
Registered: 10/02/05
Posts: 55
Location:Great White North Eh!
Hmmmmm, that is wierd. I never ran into that problem. I have my filles set to 666 and folder set to 777 and all works fine. Yet the instructions say to set them to 754.
I've Gone To Find Myself. If I Show Up Before I Return, Make Me Wait Here Until I Get Back.

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
666 works, but I couldn't remember. My files are 644, server default. So I just opened all the way up and configured it and changed it back.

It seems like he also has this file in 644, since he is using CPanel.

Sam

Status: offline

Blaine

Forum User
Full Member
Registered: 16/07/02
Posts: 1233
Location:Canada
The permissions required depend on your server or hosting setup. If the PHP process is running under the same user as the owner of the files and directories then 7 5 4 would be all that is required. As the owner would only need write access but few hosted environments are setup this way.

If the PHP process or webserver is running under the group user ID then adding write access for the group would only be required - 764 or 774 or maybe 664.

But often this is not the case and you must set write access for world/everyone - 777 or 666.


Geeklog components by PortalParts -- www.portalparts.com

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
Quote by Vapour71: I don't have any files in any of my temp directories either however, where do you have all of your files located for your filemgmt? You Should have .
public_dir/admin/plugins/filemgmt
public_dir/filemgmt
public_dir/filemgmt_data (with all sub-directories)
public_dir/plugins/filemgmt

What filemgmt files do you have in those files except for your downloadable files for your users?



Mine is like this:
ainurcc.com/Trig/admin/plugins/filemgmt
ainurcc.com/Trig/filemgmt
ainurcc.com/filemgmt_data (with all sub-directories)
ainurcc.com/Trig/plugins/filemgmt

Samstone was right about the permissions on filemgmt.php. The permissions had to be changed for the settings to stick. I have that working now. I just need the upload paths to be right

Status: offline

Vapour71

Forum User
Chatty
Registered: 10/02/05
Posts: 55
Location:Great White North Eh!
Ok. Am I to assume that /Trig/ is your root directory? If so then, have you tried putting your filemgmt_data directory in:
ainurcc.com/Trig/filemgmt_data/ (with all sub-directories)
and then set all the permissions as per your server requirements? Give that a try and see if that fixes it. Your paths should be the same as I stated in earlier post but with the addition of the following marked with the asterisk:
ainurcc.com/Trig/admin/plugins/filemgmt
ainurcc.com/Trig/filemgmt
*ainurcc.com/Trig/filemgmt_data (with all sub-directories)
ainurcc.com/Trig/plugins/filemgmt

Let me know how you made out.
I've Gone To Find Myself. If I Show Up Before I Return, Make Me Wait Here Until I Get Back.

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
I changed the files locations as you suggested. I set config to this:


$filemgmt_FileStore = "/Trig/filemgmt_data/files/";
$filemgmt_SnapStore = "/Trig/filemgmt_data/snaps/";
$filemgmt_SnapCat = "/Trig/filemgmt_data/category_snaps/";
$filemgmt_FileStoreURL = "http://www.ainurcc.com/Trig/filemgmt_data/files/";
$filemgmt_FileSnapURL = "http://www.ainurcc.com/Trig/filemgmt_data/snaps/";
$filemgmt_SnapCatURL = "http://www.ainurcc.com/Trig/filemgmt_data/category_snaps/";

I get this error:

Warning: move_uploaded_file(/Trig/filemgmt_data/files/tmp/1Mpq7QJsPA.gif): failed to open stream: No such file or directory in /home/ainurcc/public_html/Trig/filemgmt/submit.php on line 118

Warning: move_uploaded_file(): Unable to move '/tmp/phpuupMw2' to '/Trig/filemgmt_data/files/tmp/1Mpq7QJsPA.gif' in /home/ainurcc/public_html/Trig/filemgmt/submit.php on line 118

Warning: Cannot modify header information - headers already sent by (output started at /home/ainurcc/public_html/Trig/filemgmt/submit.php:11 in /home/ainurcc/public_html/Trig/lib-common.php(973) : eval()'d code on line 1

I know it is the path in the config that is wrong. I tried it with /home/ainurcc/Trig/... as well as just Trig/... In the instructions it shows an e: in front of the path and in the config panel it sugested a g: . I am just confused.

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
Quote by Kaede: I changed the files locations as you suggested. I set config to this:


$filemgmt_FileStore = "/Trig/filemgmt_data/files/";
$filemgmt_SnapStore = "/Trig/filemgmt_data/snaps/";
$filemgmt_SnapCat = "/Trig/filemgmt_data/category_snaps/";
$filemgmt_FileStoreURL = "http://www.ainurcc.com/Trig/filemgmt_data/files/";
$filemgmt_FileSnapURL = "http://www.ainurcc.com/Trig/filemgmt_data/snaps/";
$filemgmt_SnapCatURL = "http://www.ainurcc.com/Trig/filemgmt_data/category_snaps/";

I get this error:

Warning: move_uploaded_file(/Trig/filemgmt_data/files/tmp/1Mpq7QJsPA.gif): failed to open stream: No such file or directory in /home/ainurcc/public_html/Trig/filemgmt/submit.php on line 118

Warning: move_uploaded_file(): Unable to move '/tmp/phpuupMw2' to '/Trig/filemgmt_data/files/tmp/1Mpq7QJsPA.gif' in /home/ainurcc/public_html/Trig/filemgmt/submit.php on line 118

Warning: Cannot modify header information - headers already sent by (output started at /home/ainurcc/public_html/Trig/filemgmt/submit.php:11 in /home/ainurcc/public_html/Trig/lib-common.php(973) : eval()'d code on line 1

I know it is the path in the config that is wrong. I tried it with /home/ainurcc/Trig/... as well as just Trig/... In the instructions it shows an e: in front of the path and in the config panel it sugested a g: . I am just confused.


It has to be /home/ainurcc/public_html/Trig/filemgmt_data/blah blah.

You can't start from Trig, and there is a "public_html" that you are missing in your other try.

Sam

Status: offline

Kaede

Forum User
Junior
Registered: 02/07/05
Posts: 15
Fixed what Sam pointed out. Now I get this:

Error Code: 9999


ERROR: OOPS! God Knows

Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
I have heard this "God Only Knows" problem before, but could never reproduce it. It happened on my wife's computer, and we were dealing with the same website, and I didn't encounter what she did. Could that be a cookies issue? God only knows!

I found a posting on Blaine's site PortalParts.comregarding this issue in 2003, but no solution was posted.

Are you using the latest version? Try to replace the files and see if you still get that. Or try it on another computer, or delete the cookies and try again.

Sam

All times are EDT. The time is now 05:50 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content