Welcome to Geeklog Saturday, November 17 2018 @ 12:23 am EST

Geeklog Forums

G2Bridge support


Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois

G2Bridge for Gallery 2.1 has been released.


Formerly GL_Gallery2 this version has been fully updated to take advantage of the all new Gallery 2.1 API.


Note: This version does not work with Gallery 2.0.x Only with 2.1 or greater.


  • v1.0 [18 Mar 2006] Forked to G2Bridge for compatibility with Gallery 2.1

    • [new] Fully updated Gallery 2.1 API
    • [new] Added option for My Gallery link (for use with User Album Module) as apposed to Gallery2 link in User Menu
    • [new] Added option for alternate login redirect in config.php
    • [fix] Now adds installing user to G2 Admin Group instead of mapping user G2 admin user (which may not exsist)
    • [fix] No More Path Confusion


You can get this fabulous plugin here. And support can be found on my site here, and geeklog right here.


FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
excited
Hey, Gallery 2.1 has officially been released

get it here.

and while your at it, pick up a copy of our bridge.


FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

wikki

Forum User
Newbie
Registered: 22/02/03
Posts: 2
integration didn't work out for me. whenever i try to deinstall the old plugin, it just shows me a white page (the same if i use the new functions.inc). if i use the extra functions.inc that is supposed to be used for the deinstallation, it doesn't do anything.
after deleting the plugin manually from the plugins table and starting from scratch, it runs the installation but points to /admin/plugins/G2Bridge/install/
this folder doesn't exist though. if i point to install.php i get
PHP Formatted Code
Fatal error: Call to undefined function: plugin_chkversion_g2bridge() in /var/www/vhosts/pfuy.de/httpdocs/admin/plugins/G2Bridge/install.php on line 48
 


using GL 1.4.0sr2
Gallery2.1.0

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Which version of GL_Gallery2 were you using?
The functions_upgrade_to_G2Bridge.inc was copied directly from GL_Gallery2 v.0.5.0, with just the function to remove users from Gallery disabled.

What does your error.log say?


as for the undefined function, make sure the normal G2Bridge functions.inc is in path_to_geeklog/plugins/G2Bridge/

If you removed the plugin manually, I don't see any problem simply installing G2Bridge.

Hope this helps
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

julianna

Anonymous
I am receiving a simmilar error:


Fatal error: Call to a member function on a non-object in /home/julianna/plugins/G2Bridge/functions.inc on line 689


The last line in my error.log file is:


Mapping users from GL into G2


The plugin seems to have partially installed, but when I go to the Gallery2 config from the GL admin menu, I receive the following:


username: [Julianna]
fullname: [Julianna Yau]
hashedpassword: [*removed for security*]
email: [*removed for anti-spam*]
creationtimestamp: [1058386020]

Failed to create G2 user with extId [4 - 4] Here is the error message from G2:
Error (ERROR_COLLISION)

* in modules/core/classes/GalleryUser.class at line 154 (gallerycoreapi::error)
* in modules/core/classes/GalleryEmbed.class at line 360 (galleryuser::create)
* in /home/julianna/plugins/G2Bridge/functions.inc at line 585 (galleryembed::createuser)
* in /home/julianna/public_html/sculpture_gallery/index.php at line 59


I am using Gallery 2.1

I took a look at functions.inc, and found this line at 690:


$res = GalleryCoreApi::addUserToGroup( $G2_uid, 3); //G2 admin groupid is 3


I do not have a user with the ID of 3. Could this be creating the problem?

Thanks.

Julianna

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
The problem is caused when you are trying to add(map) a user from geeklog to gallery that already exsists in gallery.

try a couple of the techniques in this thread here.

and the 3 is the admin groupid in gallery that we were trying to add you to.
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
caffeinated
G2Bridge v1.1 now available.


v1.1 [5 Apr 2006]


o [new] Added option for displaying left and right blocks in config.php
o [fix] Now correctly maps users that pre-exsist in both apps, no more collisions.
o [fix] Gallery2 sidebar now displays properly.


You can get the update here. And support can be found on my site here.

FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Hey All, I've just released G2Image Chooser for G2Bridge.

This plugin for FCKeditor lets you browse and add images from your gallery directly into your stories!

How cool is that?

Get it here.

and support can be found here.


FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Thomas Bosboom

Anonymous
Thanks a lot for your hard work!

Just a small remark: I noticed that the Random Photo block seems to take up quite a lot of CPU time, any thoughts on reducing this? Maybe it would be possible to limit the random photo's to the last album or something.

PlaygroundPeople

Anonymous
Hi,

I tried to install this plugin (G2Bridge1.1_current.zip) but I also just get a blank screen after clicking "install".

I am using Gallery 2.1.1 with GL 1.4.0sr5-1.

My G2 install is at public_html/g2 and my GL is at public_html/gl.

Below is part of the plugins config.php:

PHP Formatted Code
$_G2B_CONF['public_dir'] = 'G2Bridge';

/* I think with Gallery 2.1 we have finally done away with the path confusion. I have set these to the default with gallery2 in your public_html directory.
    You should only need to change these IF gallery2 is NOT in your public_html directory.
*/


$_G2B_CONF['G2_path'] = $_CONF['path_html'].'/g2'; // full system path to your gallery2 install no trailing /

$_G2B_CONF['embedUri'] = $_CONF['site_url'].'/'.$_G2B_CONF['public_dir'].'/index.php?';   // full url to your G2Bridge index.php with trailing ?

$_G2B_CONF['g2Uri'] = $_CONF['site_url'].'/g2/';  // full url to you gallery2 with trailing /
 


error log stops at "Mapping users from GL into G2"

Sorry I tried to create an account at the support site but it didn't work.

Thanks in advance,

PlaygroundPeople


Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
it seems your paths are not quite right .

you should try full system path ie.
$_G2B_CONF['G2_path'] =' /usr/home/local/htdocs/public_html/g2';

if both gl and g2 are in public_html, $_CONF['path_html'] would not work.

Hope this helps.

-s

FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

greenteagod

Anonymous
My question concerns the sidebar image block clutter. It seems as though having it replicate the image blocks is pointless as when you click on the gallery it looks awful with them replicated right next to each other.

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
So was there a question?
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

greenteagod

Anonymous
Is there a way to have the image block function of the bridge be useful? If you have to have the blocks showing in your gallery it makes them showing in geek log sort of redundant. Is there a way to add the set of blocks without having them showing in gallery?


Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
Sure.
in public_html/G2Bridge/index.php

around line 88 just before:
PHP Formatted Code
$g2data = GalleryEmbed::handleRequest();

add:
PHP Formatted Code
$gallery->setConfig('showSidebarBlocks', false);

this tells gallery not to show its sidebarblocks.


-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

greenteagod

Forum User
Junior
Registered: 08/04/07
Posts: 19
Beautiful, was that something I missed in the readme? I've come across a few other forums where people were looking for this exact thing. I guess they didn't make it to the actual geeklog page. Definitely a setting you'd want to add to the file, unless it was already there and I was too daft to catch it. Either way, thank you very much.

One more thing if you have a moment. Is it possible to edit the heading of the blocks. Right now it just says Gallery2. If I could change that to a linked image it would suit my tastes a bit better, though if this isn't possible I understand. Thanks.

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
The block title is inserted into the db and geeklog does not support html for block titles
But there is a way to use images for block titles.

in public_html/layout/yourtheme/blockheader-left.thtml
geeklog calls the title here:
PHP Formatted Code
<h2>{block_title}</h2>

and I've been known to use this instead:
PHP Formatted Code
<img title="{block_title}" alt="{block_title}" src="{layout_url}/images/{block_title}.gif" />

Although at this point all block titles will be replaced with images(.gif) of the same exact name.

Beautiful, was that something I missed in the readme?

No, but it was in my forums on mysite prior to my moving it.
And I did not move all the old forums with it sorry.

Also I should get off my but and release an update as there are a couple of minor changes since Gallery 2.2 and GL 1.4.1

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

AngryEngine

Anonymous
1) I want the block to appear at a specific image size with the HTML title correctly appearing instead of <a href="">A sample photograph</a> on display at the museum should appear as A Sample Photograph on display at the museum.

2) Furthermore, it would be helpful if the block appeared on the footer independently from the right/left blocks is this possible?

3) How do I set the block NOT to link to the gallery image URL and just be graphically imbedded?

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
There are some config options for random photo block in path_to_geeklog/plugins/G2Bridge/config.php
and more info can be found in your gallery admin->image block

Also I have made a flash-based mini slideshow which you are welcome to.

-s
FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

AngryEngine

Anonymous
angelic


In the G2Bridge block, I want to edit the layout and HTML size of the Times New Roman text which does not match my CSS. I can't find which file to edit that will make minor adjustments to the way the image block appears - i.e. spacing, fonts...

Also, is there not a way to place the image block in the footer rather than block?

All times are EST. The time is now 12:23 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content