Welcome to Geeklog Saturday, July 11 2020 @ 01:41 pm EDT

Geeklog Forums

Probleming installing.


Newbie help

Anonymous
Hello.
I am having a problem installing my Geeklog. When i go to admin/install/install.php and set it where the config.php file is. i get theese errors

Warning: main(/usr/home/agriffin/public_html/system/classes/template.class.php): failed to open stream: No such file or directory in /usr/home/agriffin/public_html/admin/install/install.php on line 603

Fatal error: main(): Failed opening required '/usr/home/agriffin/public_html/system/classes/template.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /usr/home/agriffin/public_html/admin/install/install.php on line 603


I've looked over my configuration file serveral times, help would be much appreciated. Neutral
 Quote

Status: offline

geKow

Forum User
Full Member
Registered: 12/01/03
Posts: 445
Hmmm....
the system folder shouldn't be inside the public_html folder. So I GUESS you have a path problem. What did you set for $_CONF['path']? It should be the path to the folder where config.php is.

geKow
 Quote

LuckyDucky

Anonymous
the path i set in my config.php file is

// This should point to the directory where your config.php file resides.
$_CONF['/usr/home/agriffin/'] = '/path/to/geeklog/'; // should end in a slash


and


// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['/usr/home/agriffin/public_html'] = $_CONF['path'] . 'public_html/';



is this correct?
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Quote by LuckyDucky: the path i set in my config.php file is

// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['/usr/home/agriffin/public_html'] = $_CONF['path'] . 'public_html/';

is this correct?


No.

$_CONF['path_html'] = '/usr/home/agriffin/public_html';
 Quote

LuckyDucky

Anonymous
HUH? sry im a little lost in php. im new to this. i dont see waht u are saying no to. could u explain? Frown

thx very much!
 Quote

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/03
Posts: 807
Your settings were incorrect. Replace the lines you posted with the one that I gave you.
 Quote

LuckyDucky

Anonymous
i still get the error installing when i go to http://www.anoobslife.com//admin/install/install.php and specify this for a location
/usr/home/agriffin/public_html/config.php
or i get the same error when i specify it like this
/usr/home/agriffin/public_html/
 Quote

Status: offline

geKow

Forum User
Full Member
Registered: 12/01/03
Posts: 445
Maybe you should start over again, with a fresh version of the config.php. Wink

If you don't change the geeklog filestructure you need to set only one path in the config.php.
This is : $_CONF['path']

The line should look like this:
PHP Formatted Code
$_CONF['path'] = '/usr/home/agriffin/';
 
so this is pointing to the directory where your config.php is.

You don't need to alter $_CONF['path_html'], if you kept the original directory structure, because the default value is
PHP Formatted Code
$_CONF['path_html'] = $_CONF['path'] . 'public_html/';

 
that means it calls the variable with the path you set before (wich is /usr/home/agriffin/) and adds an public_htm/.

The next thing you need to set is the URL (aka Webadress) of your page
PHP Formatted Code
$_CONF['site_url']          = 'http://YOURWEBADRESS. HERE';
 


These are the only two pathes you need to set if you keep the original directorystructure!

Geeklog is clever eneough to "calculate" all the other pathes it needs by its own. Smile

geKow
 Quote

All times are EDT. The time is now 01:41 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content