Welcome to Geeklog Wednesday, July 17 2019 @ 02:25 am EDT

Geeklog Forums

geeklog 1.3.8-1sr2 fresh install not working: sql error


telluride

Anonymous
tired
Hi guys,
Just wanted to see if anyone knew why I am having trouble with a fresh install of the latest build (tried both 1.3.8sr1 and sr2).

Basically, i run the install script with no problem, but then when i go to the site, i get "an sql error has occurred. please see error.log for details.

I'm running on OS X Jaguar (10.2.8) with mysql version 3.23.56-1 (installed by fink), apache version 1.3.27 and php version 4.1.2 (standard Jaguar). /sw/bin is part of the system path (where fink installs executables)

The file permissions and SQL user permissions seems to be correct, but I get the following error in error.log (this is on trying to access the main page - ie 127.0.0.1:

Wed Oct 15 15:54:16 2003 - 1064: You have an error in your SQL syntax near '= gl_comments.sid) AND (gl_stories.perm_anon >= 2) AND (gl_stories.draft_flag = ' at line 1. SQL in question: SELECT DISTINCT count(*) AS dups, type, question, gl_stories.title, gl_stories.sid, qid, max(gl_comments.date) as lastdate FROM gl_comments LEFT JOIN gl_stories ON ((.sid = gl_comments.sid) AND (gl_stories.perm_anon >= 2) AND (gl_stories.draft_flag = 0) AND (tid IN ('General','GeekLog'))) LEFT JOIN gl_pollquestions ON ((qid = gl_comments.sid) A
ND (gl_pollquestions.perm_anon >= 2)) WHERE (gl_comments.date >= (DATE_SUB(NOW(), INTERVAL 172800 SECOND))) AND ((((gl_stories.perm_anon IS NOT NULL))) OR (((gl_pollquestions.perm_anon IS NOT NULL)))) GROUP BY gl_comments.sid ORDER BY 7 DESC LIMIT 15



(could it be the AND split on two lines?)

I tried loading another sql database from a working geeklog database dump, but i got the same problem. Any help would be GREATLY appreciated.

Thanks,
irby

telluride

Anonymous
ok, solved my own problem. For some reason this long query in lib-common.php is wrapped in the middle of an AND. pulling this line back into one piece fixes everything nicely!

i used BBEDIT to pull it back together as attempts to do it in pico kept failing.


Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Same problem as here. No solution yet (and no idea what's causing it), but a workaround ...

Interestingly enough, all reports so far seem to come from MacOS X users. I'm using MacOS X myself and have never seen this problem - but then again I'm using my own builds of Apache and PHP and an updated MySQL ...

bye, Dirk

Status: offline

jjkemp

Forum User
Newbie
Registered: 31/12/03
Posts: 1
Quote by Dirk: Same problem as here. No solution yet (and no idea what's causing it), but a workaround ...


I also suffered the same poblem and I noticed the same thing as telluride, the lines on lib-common.php had been cut to several rows when path had been edited.

I'm running Solaris, edited file with pico. The workaround I used was to use fresh lib-common -file, edited it in windows and then transferred the file to the server. Never opened it in pico.

I hope this will help sort some troubles out...

--jjkemp

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Yeah, it really looks like pico is wrapping some of the long lines (it even tells you about it when you load the lib-common.php). Doesn't quite explain all the effects people have been describing here, but it's certainly a good idea to stay away from pico and use a better text editor (like vi ) instead ...

bye, Dirk

All times are EDT. The time is now 02:25 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content