Welcome to Geeklog Monday, November 18 2019 @ 06:20 am EST

Geeklog Forums

geeklog-1.3.8rc1 does not allow me to fully login


Status: offline

vbgunz

Forum User
Full Member
Registered: 24/01/03
Posts: 169
I\'ve decided to do a fresh install of Geeklog 1.3.8 just to check up on it and it seems I am having a very difficult time at logging in. My entire server setup is the absolute same (Apache, PHP, MySQL) except now a new database for 1.3.8. When I enter the credentials (Admin - password) I can see that I am logged in under whos online but my admin panel never comes up. In fact the login box is still there and it is as if I am not logged in... Also, after a few attempts the whos online block goes back to guest users 1 and an attempt to login presents me with forgot your password. I see others are enjoying it and I never thought something like this would happen but it did. Can someone offer me some insight on this? Thank you Smile
Victor B. Gonzalez - http://aeonserv.com

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
I was actually waiting for the first post like this Wink The cookie handling has changed slighlty in Geeklog 1.3.8, thus you may experience problems when you still have the old cookies stored in your browser. So tip #1 would be to remove the cookies for your site and try logging in again. If that still doesn't resolve it, then tip #2 would be to set the $_CONF['cookiedomain'] variable in config.php to something like
PHP Formatted Code
$_CONF['cookiedomain'] = '.example.com';
where "example.com" is your domain (notice there are two dots). bye, Dirk

Status: offline

vbgunz

Forum User
Full Member
Registered: 24/01/03
Posts: 169
Thank you Dirk, that solved the problem! I am in... Thanks again Smile
Victor B. Gonzalez - http://aeonserv.com

LewisR

Anonymous
I\'m seeing the same problem (among others). I\'ve set cookiedomian properly, but still get bounced back to the login screen. Besides that, I can\'t seem to get php to fire up sendmail (though I\'ve verified that sendmail is working form the command line). Apache 2.0.46 under OS/2 4.5.1 PHP 4.3.1 MySQL 4.0.1 under NetWare 6 SP3 Geeklog 1.3.8rc1 Any ideas? Something I can do to check to see if everything should be working (status, etc.)? Thanks! Lewis

lean4huskytop

Anonymous
And I am having the same problem. I am hosting the test site under my own machine and my cookie domain name cant be .site.com because its \"localhost:8090/geeklog-1.3.8/public_html\" so that didnt work and now I am still stuck. Sendmail says I am sending a message and norton antivirus checks the outgoing message for viruses but I am not getting any emails. wats goin on? Smile

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by lean4huskytop:I am hosting the test site under my own machine and my cookie domain name cant be .site.com because its \"localhost:8090/geeklog-1.3.8/public_html\"
You can set \'cookiedomain\' to \"localhost\". Also make sure that you include the port number in the site_url variable. bye, Dirk

lean4huskytop

Anonymous
Hi Here is what I have in the siteurl: $_CONF[\'site_url\'] = \'http://localhost:8090/geeklog/public_html\'; The index.php file is in the public_html directory. Is this path correct?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Looks okay, as far as I can tell from here ... bye, Dirk

lean4huskytop

Anonymous
I went through everything...its not letting me log in. I put Admin and password and its just clicking away but nothing is happening. What else can be wrong?

Status: offline

buddilla

Forum User
Newbie
Registered: 31/01/04
Posts: 9
I have the same problem. Heres Whats going on with Debug on.
---- DEBUG ----
loginname [Admin]


passwd [password]



---------------

Warning: Cannot modify header information - headers already sent by (output started at /Library/WebServer/Documents/users.php:55) in/Library/WebServer/system/lib-sessions.php on line 310

Warning: Cannot modify header information - headers already sent by (output started at /Library/WebServer/Documents/users.php:55) in/Library/WebServer/Documents/users.php on line 856

Warning: Cannot modify header information - headers already sent by (output started at /Library/WebServer/Documents/users.php:55) in/Library/WebServer/Documents/users.php on line 859

Warning: Cannot modify header information - headers already sent by (output started at /Library/WebServer/Documents/users.php:55) in/Library/WebServer/Documents/users.php on line 886

not sure if this is normal.
My Brain Hurts Now haha. Rockstar n' Halo will fix that

Status: offline

keystone430

Forum User
Chatty
Registered: 28/01/04
Posts: 68
I had the same problem when I first installed Geeklog. I thought it was just my computer settings.

To fix it I dumped all cookies and temp files then closed my browser and rebooted. Worked fine for me. The next time I logged in the admin panel was there.


Status: offline

buddilla

Forum User
Newbie
Registered: 31/01/04
Posts: 9
happy
Tried that. HAHA that was the first thing i tried.
Iv tried Everything in the forums. I know cookies work.
They work for phpmyadmin. It must be how geeklog
works on sending them. Iv tried differnt browsers
Explorer/safari i dont even recieve a cookie.
i even turned off the encryption feature nuttin is working.
I am using A fresh install/updated version of panther.
Could this be the cause. I dought it thou.
Dual 500mhz G4
OSX 10.3.2

(Edit)
Apache/1.3.29 (Darwin) PHP/4.3.2

The Cookies Are Being Sent

Server: Apache/1.3.29 (Darwin) PHP/4.3.2
X-Powered-By: PHP/4.3.2
Set-Cookie: LastVisit=1075691081; expires=Tue, 01-Feb-2005 03:04:41 GMT; path=/; domain=.local
Set-Cookie: LastVisitTemp=deleted; expires=Sun, 02-Feb-2003 03:04:40 GMT; path=/; domain=.local
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html

the .local is one out of many attempts to set the url.
I have a router/dsl modem with port forwarding set to
my server. So That shouldnt be the problem cus
im getting cookies from geeklog.net its self. Maybe im wrong.

Status: offline

vbgunz

Forum User
Full Member
Registered: 24/01/03
Posts: 169
Hello,

I believe this is noted with the developers but am not sure. It seems Geeklog doesn't like a machines name. e.g. it doesn't like "mymachine" but it loves "127.0.0.1".

In other words, unfortunately at the moment and I am not sure if Geeklog has addressed the issue, you'll most likely have to network with your IP address and not your machines name...

So "mymachine" doesn't work whereas "192.168.0.24" would be good for a network setup. This includes "localhost". Simply do not use your machines name and neither use "localhost". Supplement them with either your loopback "127.0.0.1" or a network IP like "192.168.*".

Good luck!

Victor B. Gonzalez - http://aeonserv.com

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by buddilla: OSX 10.3.2

The Rendezvous name for the server may cause the problem here. See this thread.

bye, Dirk

Status: offline

buddilla

Forum User
Newbie
Registered: 31/01/04
Posts: 9
Alright well i got cookies to get accepted.
Yet only Cookies for LastVisit n' LastVisitTemp
are being accepted/sent. the only way i could
get them was to not set the:
// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url'] = '';

with

$_CONF['cookie_ip'] = 0;
$_CONF['default_perm_cookie_timeout'] = 604800; //604800
$_CONF['session_cookie_timeout'] = 7200; //7200
$_CONF['cookie_path'] = '';
$_CONF['cookiedomain'] = ''; // e.g. '.example.com'
$_CONF['cookiesecure'] = 0;

this is the only way i get a cookie.
even with my httpd.conf up with a server name.
im running out of idea's im close to ending the problem
with a little help. thanks for the help. Wink
(edit)
could this be caused by the way Apache handles cookies
now. I'v tried it with usertrack on n' off it has the same effect.
After this is all figured out im going to make an OSX package
for this stuff.

Status: offline

buddilla

Forum User
Newbie
Registered: 31/01/04
Posts: 9
Alright so i found out what the problem was
I HAD DEBBUG ON. LOL...
I dont know that it is a feature to prevent login when debug is on. Either way it should be documented. I guess it is now.
ha. So all is good time to make that OSX Installer Package.

All times are EST. The time is now 06:20 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content