Subject: WinCVS and SourceForce

Posted on: 09/09/01 12:18am
By: MLimburg

I spent many a day and sleepless night attempting to get Windows, SSH, WinCVS and Sourceforge to play night together. Then, one stormy night, it happened! Lightning flashed, the Ghods cursed my very existance, but IT WORKED! Okay, so it may have only been a light shower, and I may have splurted my coffee once it did connect correctly, but I've managed to write down the steps involved to getting it all together.
  1. Download and install 1.3 Beta of WinCVS, PuTTY and PLink . I put them all into one subdirectory.
  2. Create a CVS subdirectory on your hard drive, so you have a location to place the CVS files once you have them.
  3. Start up PuTTY and connect to "" using the SSH protocol. PuTTY will ask to add the sourceforge key to the cache, to which to smile and click yes. Putty has now done it's job; you can exit it and move on.
  4. Start up WinCVS. From the menu system, select Admin, and Preferences.
  5. Set the authorisation to "ssh", path to "/cvsroot/geeklog", host address to "", and your sourceforge username into the user name field.
  6. Click the Settings button next to the SSH selection.
  7. Check the "If SSH is not in path" checkbox, and browse your hard drive, selecting the PLINK file.
  8. Check the "Addional ssh options" checkbox and enter "-ssh -pw password" ... only make sure you enter your sourceforge password here.
  9. Click OK twice.
  10. From the menu, select View, Browse, Change Location, and select the new CVS subdir you created back in step 2.
  11. Right click on the module section on the left, and select Checkout Module.
  12. From this dialog box, you select the specific module you want. For example, "geeklog-1.3" will grab the 1.3 beta we're currently working on.
  13. Download the CVS and Giggle.
This worked for me. It doesn't ask for passwords all the time, and it allows me to double-click on the file from within WinCVS to auto load (in my case) Paint Shop Pro and Homesite. I've found it to be fast, simple and damn powerful. If you have any problems, please feel free to post them below and I'll do my best to figure it out for you.

WinCVS Instructions...

Posted on: 10/09/01 08:11am
By: Anonymous

I tried the series of instructions you have provided and when the CheckOut of "/geeklog-1.3" is complete nothing is downloaded to my local CVS directory. Help. ** ALSO -> This awful I.D. (Username) I'm logged in with is as a result of the system providing me (in the confirmation email) something other than I supplied during the account creation process. I've posted a bug report on SourceForge on this issue.

WinCVS Instructions...

Posted on: 05/10/01 08:35pm
By: MLimburg

Ooops .. It's not '/geeklog-1.3' .. it's 'geeklog-1.3' .. sorry

Testing the Process

Posted on: 10/10/01 04:12pm
By: MLimburg

Well, after a nasty partition crash, I had to reinstall my entire suite of apps. I followed the instructions up here to the letter, and it worked like a charm. So, there's no excuse now for Windows developers. Get out there and grab the CVS!

Geeklog - Forum