Subject: Log in ID is not saved in safari.

Posted on: 17/03/19 05:55am
By: OMAL

Log in ID for geeklog.net is not saved in safari.
For log in ID of my site of gl2.1 and this site https://www.geeklog.jp/users.php?mode=login is saved in safari .
I think the difference is geeklog.net is using reCaptcha.
Is it only me?
I have this issue for about a half year.

safari 12.0.3 mac OS Mojave

Re: Log in ID is not saved in safari.

Posted on: 17/03/19 10:02am
By: Laugh

Are you referring to the browser saving your login information so the next time you need to log into the geeklog site it auto fills the username and password in the login form?

Re: Log in ID is not saved in safari.

Posted on: 18/03/19 06:57pm
By: OMAL

Quote by: Laugh

Are you referring to the browser saving your login information so the next time you need to log into the geeklog site it auto fills the username and password in the login form?


Yes.

Re: Log in ID is not saved in safari.

Posted on: 19/03/19 07:10am
By: OMAL

Solved.
It was browser's fault. And when I upgraded MacOS from highSierra to Mojave, key chain in Safari was disappeared, that was also one of the cause. Anyway, Now it's OK.

Re: Log in ID is not saved in safari.

Posted on: 19/03/19 07:14am
By: Laugh

This one is hard for me too test as I have a PC. I have tested with Chrome, FireFox and Edge and all seem to remember passwords fine on the Geeklog.net login page (with the recaptcha enabled).

ReCaptcha may send a request not save passwords. You can disable these type of requests in Safari apparently. Quoted from Cnet:

To do this, go to the Passwords section of Safari's preferences, where you will see a checkbox at the bottom of the window which says "Allow AutoFill even for websites that request passwords not be saved." Toggle this setting, and you should now be able to save your site's password.

Re: Log in ID is not saved in safari.

Posted on: 19/03/19 09:25am
By: OMAL

Well, the thing is, password saving was disabled only for the geeklog.net in that section, but still the browser offers options for saving password when I enter ID as if it works fine, so it was flaw. I enabled password saving for geeklog.net to solve it.

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=96994