Subject: Mediagallery 1.6.12 error

Posted on: 28/05/12 01:27pm
By: Anonymous

When i trying to install plugin i got:

PHP Fatal error: Call to a member function fetch_array() on a non-object in system/databases/mysqli.class.php on line 604

Geeklog 2.0.0, Mediagallery 1.6.12 (fresh install)
Apache/2.2.22 (Gentoo) PHP/5.4.2--pl0-gentoo
mysql Ver 5.1.62-log for pc-linux-gnu on i686 (Gentoo Linux mysql-5.1.62-r1)

Stack trace:

PHP Fatal error: Call to a member function fetch_array() on a non-object in /home/server/www/htdocs/system/databases/mysqli.class.php on line 604, referer: http://localhost/admin/plugins.php
PHP Stack trace:, referer: http://localhost/admin/plugins.php
PHP 1. {main}() /home/server/www/htdocs/public_html/admin/plugins/mediagallery/install.php:0, referer: http://gnubox.lt/admin/plugins.php
PHP 2. require_once() /home/server/www/htdocs/public_html/admin/plugins/mediagallery/install.php:35, referer: http://localhost/admin/plugins.php
PHP 3. DB_fetchArray($recordset = *uninitialized*, $both = *uninitialized*) /home/server/www/htdocs/plugins/mediagallery/functions.inc:92, referer: http://localhost/admin/plugins.php

Xdebug output:
http://i.imgur.com/Kf8un.png

Any ideas what Im doing wrong?

Re: Mediagallery 1.6.12 error

Posted on: 29/05/12 05:47pm
By: Laugh

When I try the install on Geeklog 2.0.0 I get a strange error reporting that Geeklog version is not v1.4.0 or higher.

Looking quickly at the Media Gallery install code I also see that a few blocks are inserted into the blocks table. Doing it this way will not work with Geeklog 2.0.0 since the blocks table has changed. The Mediagallery plugin will have to be updated before it can work.

You could try contacting the plugin author to see when he plans to do this.


Re: Mediagallery 1.6.12 error

Posted on: 04/06/12 10:33am
By: dengen

Hi minde,

Thank you for your report.
I has released new version to resolve the problem.
http://www.trybase.com/~dengen/log/downloads/index.php/mediagallery-wkz_1.6.13_en

In the near future, I plan to release a new version with full support for the functionality of the Geeklog2.0.0.

Thanks.

dengen

Re: Mediagallery 1.6.12 error

Posted on: 08/04/13 11:58am
By: Laugh

I am using an older version of media gallery (1.5.0) on one of my sites and noticed that the album slideshow feature doesn't work on IE 10. Does it work in the Media Gallery 1.6.3?

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=94146