Subject: UTF-8

Posted on: 19/08/11 05:44pm
By: Zippo

FYI
After I installed the dokuWiki plugin, I could not make a proper Wiki while my special characters did not converted properly by DokuWiki.

Dokuwiki Forum support, told me to change the browser setting to UTF-8. No result.

This evening: Idea
I renamed the geeklog language file dutch.php into dutch_org.php.
I copied the geeklog language file dutch_UTF8.php into dutch.php.

Problem Solved!

-=-=-=-=-=-
But was this the right way I supposed to do it?
I could nowhere find an option in geeklog configuration panel to choose UTF-8.
Also in My account / language list... only 1 dutch language.
-=-=-=-=-=-

Re: UTF-8

Posted on: 19/08/11 08:25pm
By: Laugh

In step 2 of the Geeklog install is the option to select UTF-8.

To manually change it for a site you are already running you will have to edit siteconfig.php found in the public_html directory.

PHP Formatted Code
$_CONF['default_charset'] = 'utf-8';


You should also then convert your database to utf-8. Take a look at this article. There also was a good forum post about this from a few years ago but I can't seem to find it at the moment.

Tom

Re: UTF-8

Posted on: 20/08/11 03:15am
By: Zippo

Thanks....

I searched on "utf_8", that's why I missed it Frown

Ok.. have some work tot do... Wink

Thanks again,

Grtz.
Zippo

Re: UTF-8

Posted on: 20/08/11 03:33am
By: Zippo

Hmmm....

When I click on localhost in myphpadmin, I see:
==================
Server: Localhost via UNIX socket
Serverversie: 5.0.92-community
Protocolversie: 10
User: xxxxxxx@localhost
MySQL Karakterset: UTF-8 Unicode ( utf8 ) (Note: I did not changed it, was already like this)
===========

But In All the databases/tables I see: "latin1_swedish_ci" everywhere..
Should I change this??

So yes....
Can somebody post a query to run... or post a solution to change this in a batch.

Re: UTF-8

Posted on: 20/08/11 06:44am
By: ::Ben

You can find a tutorial here.

Ben

Re: UTF-8

Posted on: 20/08/11 07:24am
By: Zippo

Sorry Ben,

That is not a tutorial, but a puzzle in Chinese for me.
(BTW. I can not read Chinese)

Geeklog = dutch_utf8 now.

Only all the SQL tables give latin.... (and I have over a hondred tables)
Tutorial says: I used the "replace commando" but does not say how to use it.

Just type:

REPLACE latin1_swdish_ci UTF-8 Unicode

Won't work, at least I am afraid to experiment with it.

-=-=-=-
It looks that everything works fine.

Re: UTF-8

Posted on: 20/08/11 09:35am
By: Laugh

Is this a new site? If so it would be better to just copy the information you need and then just delete the database and start fresh.

Re: UTF-8

Posted on: 20/08/11 06:36pm
By: Zippo

It is a fairly new site.

I have no strange characters anymore... so I will change the table settings in slow manual mode. (no hurry)

But I will not install GeekLog for the 4th time (twice: I have 2 sites running) Evil

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=93168