Subject: jQchat deveolpment quit?

Posted on: 10/08/11 08:56am
By: Zippo

I am looking for a chat / shoutbox INSIDE GeekLog.

jQchat looks nice, but I can not get it to work inside Geeklog 1.8.0 (block does not work properly)
On the developers site, I cannot find anything about jQchat... so it seems that support development is stopped.

Also Chatterbox I can not get to work.

Intra Messenger is nice, but except authentication, it is totally outside GeekLog.


Anybody has something (made or adapted)?

Re: jQchat deveolpment quit?

Posted on: 10/08/11 10:59am
By: ::Ben

I tryed jQchat on geeklog 1.8.0 and it is working on live site but it does not on local site (wamp).

Ben

Re: jQchat deveolpment quit?

Posted on: 10/08/11 11:10am
By: Zippo

I know.... also I made a change of the emoticons path... (which was not working in the wamp), but I still cannot type anything in the wamp.

And the wamp is just the feature what I'm looking for.
(I visited the authors site, but it is not under downloads, they are running the live chat part on their site.)
Left a comment, asking for an update.

- I found also a different shoutbox... but I cannot get it to work in a block Frown

- I tried chatterbox... crashed my site (see my post in feedback)

But hosting a game clan, an inside chat/messenger would complete the site.

Re: jQchat deveolpment quit?

Posted on: 10/08/11 05:06pm
By: Laugh

The author still does work on Geeklog stuff (though I do not know his plans for jQchat). I would try contacting him directly using his contact us form

http://www.flashyourweb.com/profiles.php?uid=3

Re: jQchat deveolpment quit?

Posted on: 10/08/11 09:26pm
By: suprsidr

make sure you're not calling a second version of jquery after jQchat's javascript is included.

use firebug to check for javascript errors.

-s

Re: jQchat deveolpment quit?

Posted on: 11/08/11 02:59pm
By: Zippo

Quote by: suprsidr

make sure you're not calling a second version of jquery after jQchat's javascript is included.

use firebug to check for javascript errors.

-s



I am sure you know what you are talking about.
I am sorry to say.... "I don't." Rolling Eyes

Re: jQchat deveolpment quit?

Posted on: 11/08/11 03:04pm
By: suprsidr

first step, get firebug for firefox.
Then open the firebug console and reload your page.
report any errors here.

If your wamp is reachable send me the url.

-s

Re: jQchat deveolpment quit?

Posted on: 11/08/11 04:17pm
By: suprsidr

looks like geeklog's data directory is not writable, no chat.txt is being created http://kom.ninanauk.net/data/
and this directory should not be reachable vis the internet.

Re: jQchat deveolpment quit?

Posted on: 11/08/11 04:32pm
By: Zippo

Strange conclusion... I see created files (342542536........ . cache) in the data dir.
(If the dir is reachable.. you could have seen those too.)

Dir was 755, I changed him into 777.

Re: jQchat deveolpment quit?

Posted on: 11/08/11 04:36pm
By: Zippo

My webroot is: ninanauk net /kom
Addon domain: kom ninanauk net
Redirected: kom ninanauk net TO kom ninanauk net /public_html

All dirs to be protected have an empty index.html so that the dir is not listed.

Re: jQchat deveolpment quit?

Posted on: 11/08/11 04:51pm
By: suprsidr

You have a server/configuration problem, this is not an issue w/ jQchat

-s

Re: jQchat deveolpment quit?

Posted on: 11/08/11 04:55pm
By: Zippo

Yes, I already fixt it.... db_config.php was damaged...
(I do not have an idea how that happended)

Re: jQchat deveolpment quit?

Posted on: 11/08/11 05:00pm
By: Zippo

Oops!

I just remebered I diasbled the wamp block.

Block is now enabled... you should be able to debug now.

Re: jQchat deveolpment quit?

Posted on: 11/08/11 05:02pm
By: suprsidr

I already debugged, the chat.txt and related files are not being created in $_CONF['path_data']

Re: jQchat deveolpment quit?

Posted on: 11/08/11 05:18pm
By: Zippo

Can you (or I with instructions) fix it?

Re: jQchat deveolpment quit?

Posted on: 11/08/11 05:30pm
By: suprsidr

I would not be able to check/do anything w/out ftp access

Re: jQchat deveolpment quit?

Posted on: 11/08/11 06:29pm
By: suprsidr

So is this the installation in public_html/beta?
if so, where is geeklog's plugins directory? I see a plugins directory, but it sure does not belong to geeklog.
Also cpanel does not allow you to have writable directories and files in a public space - I'm sure your error logs are full of errors.
you also have many php warning regarding fopen not being able to find error.log missing log directory as well as the data directory.

A cpanel environment is perfectly suited for geeklog sites as it allows directories outside of the web root(unlike plesk)

-s

Re: jQchat deveolpment quit?

Posted on: 12/08/11 02:24am
By: Zippo

I tried to send you my site map...
All I get is "Spam detetected... Message deleted!", hetre and in mail Frown

I'll try again. (Send me a normal emailaddres so I can explain. if you need more info)

Exclamation /kom is the one. Directly from webroot (/public_html/beta is the old one) Exclamation

/kct will be a second one Directly from webroot (/public_html/kappa is the old one. now running!)

As soon kom is running completely a copy will be made into kct.

I play Grepolis on 2 worlds, I want for each world a GeekLog running.

Re: jQchat deveolpment quit?

Posted on: 12/08/11 09:35am
By: suprsidr

Ok, here is what I found.
javascript errors from the flicker plugin - setting javascript in the head whereas all other js is in the footer(Ben, heads up)

Relative paths in jQchat break when geeklog is not in the site's root.(that's me)

jQuery plugin forcing jsonp on all ajax requests - looking into that now(Ben, heads up)

-s

Re: jQchat deveolpment quit?

Posted on: 12/08/11 09:51am
By: suprsidr

Switched my plugin to jsonp which fixed the immediate issue, but forcing jsonp still needs to be investigated.
I have not looked, but the jQuery plugin is probably using jQuery.ajaxSetup().

-s

Re: jQchat deveolpment quit?

Posted on: 13/08/11 07:00pm
By: Zippo

It Works!!!!

Great Job!!!! :banana:

Re: jQchat deveolpment quit?

Posted on: 13/08/11 07:21pm
By: Zippo

Ok. Thanks a lot. :chestslam:

1. Which files did you edit? (so I know which ones to copy/backup)Confused:

2. To COPY a geeklog to another folder (my second gamers gang), I think I also need to copy a number of tables of the SQL.
I supposeI have to skip all the users related.
A. Should I NOT copy ALL tables which contain the word user Confused:
B. What is the best thing to do with the gl_conf_values. copy and editConfused: Because it also contains plugin information.
C. Are there any other tables I should NOT copyConfused:



Confused:

Re: jQchat deveolpment quit?

Posted on: 13/08/11 07:28pm
By: suprsidr

I edited most files - basically updating for geeklog 1.8.x
when you clone your site, currently you'll only have to edit the 2 .js files in public_html/jQchat for the relative path to process.php
We had discussed a global javascript object for GL1.8 which contained the site_url and other specific $_CONF values, but I don't think it made the cut.


As for cloning a site.... its easy for decide a base file install based on which plugins you'll want, but just run the installer for each new site.
Its much easier than editing $_CONF values for each new site.

But I have a helpful tool for moving sites if you insist on that path.
http://www.flashyourweb.com/filemgmt/index.php?id=39

-W

Re: jQchat deveolpment quit?

Posted on: 18/08/11 06:26am
By: Zippo

Eeehhh...

Little bit Oops! to ask.. but:

Is it possible to add some kind of "beep" if the enter-key is hit in the quick chat. So you can hear somebody has type something?

Re: jQchat deveolpment quit?

Posted on: 18/08/11 08:03am
By: suprsidr

That is not a trivial request.

-s

Re: jQchat deveolpment quit?

Posted on: 18/08/11 10:24am
By: suprsidr

Ok, you had me curious, so I had to try.
HTML5 provides the new <audio /> tag which works wonders for including sound in webpages.
It works in all modern browsers including IE9 & 10
But without a flash fallback it won't work in the older browsers.(I could provide this but have no incentive)

So if you want to try the Live chat on mysite(Support -> Live Chat) and let me know what you think.

-W

Re: jQchat deveolpment quit?

Posted on: 18/08/11 01:12pm
By: Zippo

Works for me!!!
SOUNDS Great!

Re: jQchat deveolpment quit?

Posted on: 18/08/11 05:27pm
By: suprsidr

Try my update out, and let me know if you have any issues.
There should be no problems with your site not being in the root, so be sure to report back.

-s

Re: jQchat deveolpment quit?

Posted on: 18/08/11 11:30pm
By: Zippo

Quote by: Zippo

Eeehhh...

Little bit Oops! to ask.. but:

Is it possible to add some kind of "beep" if the enter-key is hit in the quick chat. So you can hear somebody has type something?



Eeeehhhhhh.....
When I am very busy at making a wiki or busy with forum......
I do not see anybody typing in the QUICK CHAT...

I thought, because on the flashyourweb site, you only have the live chat running, you used this for testing....
(Don't get me wrong, I am happy that it is the live chat too..., but I asked for the quick chat.)

Re: jQchat deveolpment quit?

Posted on: 18/08/11 11:33pm
By: Zippo

JQchat installs like a charme....

auto-install works perfectly.
No issues at all.

Re: jQchat deveolpment quit?

Posted on: 19/08/11 10:28pm
By: suprsidr

I actually found a bug w/ the sound, which I'm fixing now.
But it can work to your advantage.
Currently we're posting the javascript to trigger the sound in both full chat and block chat.
But in your page there is no audio object to catch the call and throwing a js error.
So place this just below the <body> tag in your theme's header.thtml:
PHP Formatted Code

    <audio id="soundPost" style="display:none;">
       <source src="/jQchat/sound/notify.ogg" type="audio/ogg">
       <source src="/jQchat/sound/notify.mp3" type="audio/mpeg">
       <source src="/jQchat/sound/notify.wav" type="audio/wav">
    </audio>
 

make sure to add the correct url to your jQchat sound files.

I think I'll add sound as an option in configuration and release an update.

-s

Re: jQchat deveolpment quit?

Posted on: 20/08/11 12:18am
By: suprsidr

Ok, 1.0.3 released fixed that issue, and adds a config option for sound in block chat.

-s

Re: jQchat deveolpment quit?

Posted on: 20/08/11 07:09am
By: Zippo

Works Great!

Install, no problems.

All works fine!

Thank you!!

Zippo

Re: jQchat deveolpment quit?

Posted on: 04/11/12 12:50pm
By: Armitage

I'm kind of bringing this back from the dead because I just found this plugin and installed it on my site as an alternative to the now-ancient chatterblock. I am only interested in the plugin for the quick chat block not the full-scale chat window. It's working pretty well but I was wondering if anyone might be able to help me out with the following:

1) If you go into the site configuration and adjust any of the jQchat settings, once you refresh the text in the quickchat it goes off to some random bit in the past and stops displaying the current data. Not sure how to fix this except to nuke the blockchat.txt from the admin menu.

2) I'd like to increase the number of lines displayed when a user initially loads the block (such as a page change within the site or hitting the front page initially) from 5 to possibly 10. Whenever you move between pages, the whole conversation you previously could see is lost.

3) It adds a newline every 3 lines of text which seems like a bug.

This last bit is a feature request if development is still ongoing. In the past users made heavy use of the private messaging function in chatterblock. I'd really like to see something like that in the quick chat if possible.

Thanks!

Re: jQchat deveolpment quit?

Posted on: 04/11/12 04:19pm
By: suprsidr

1) I cannot reproduce. It is good practice to remove the blockchat.txt every once in a while as it can grow very large.

2) process.php line~140
PHP Formatted Code
for ($i = ($count < 6)?0:$count-5; $i < $count; $i++) {

change the 6 to 16 and the 5 to 15

3) wordwrap every 70 characters

Feel free to pick up further development, I only plan bugfixes and security updates.

-s

Re: jQchat deveolpment quit?

Posted on: 04/11/12 04:51pm
By: Armitage

Thanks for the quick reply. I have made the change you specified and it works great! Is there any way to disable the word wrapping? I can handle little tweaks to the code but I'm afraid at this time adding whole new features is beyond me! Thanks for your help and for the plugin!

Re: jQchat deveolpment quit?

Posted on: 04/11/12 05:05pm
By: suprsidr

I believe there is only one instance of wordwrap in process.php, search for it an comment out that line.

-s

Re: jQchat deveolpment quit?

Posted on: 04/11/12 05:17pm
By: Armitage

Got it, thanks!

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=93103