Subject: Newsletter. Problem with links and images

Posted on: 25/01/11 03:22pm
By: Pushkar

I have installed Newsletter plugin to my Geeklog Site. After that i send my first letter by this plugin. In text I used images and links. But on my e-mail I got a text without images and links. In that place I see:

http://s006.radikal.ru/i215/1101/b0/87c4dc85e986.jpg

PHP Formatted Code

for link:

<a onclick="return im_fixA(this);">link</a>

for image:

<a onclick="return im_fixA(this);" title="\&quot;??????????" ????????????????="" ????????\=""><img alt="\&quot;\&quot;" height="\&quot;443\&quot;" width="\&quot;550\&quot;">


Please help me fix it. Thanks

Re: Newsletter. Problem with links and images

Posted on: 25/01/11 07:46pm
By: suprsidr

Your images and links need to be fully qualified urls.
Correct:
PHP Formatted Code
<img src="http://mysite.com/my_image.jpg"/>

Incorrect:
PHP Formatted Code
<img src="../my_image.jpg"/>


Same is true for links.
Correct:
PHP Formatted Code
<a href="http://mysite.com/index.php">My site</a>

Incorrect:
PHP Formatted Code
<a href="/index.php">My site</a>


Coding html email is a pain. Html clients all handle html differently.
An excellent article on the matter http://articles.sitepoint.com/article/code-html-email-newsletters.

-s

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 01:43am
By: Pushkar

I have put a correctly url's and images adresses

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 07:10am
By: suprsidr

I have put a correctly url's and images adresses

And what? it's working?
Or same issue?

-s

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 07:55am
By: Pushkar

Quote by: suprsidr

I have put a correctly url's and images adresses

And what? it's working?
Or same issue?

-s


I put correctly links from the start. it isn't working correctly

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 08:31am
By: suprsidr

<a onclick="return im_fixA(this);">link</a>

and
<a onclick="return im_fixA(this);" title="\&quot;??????????" ????????????????="" ????????\=""><img alt="\&quot;\&quot;" height="\&quot;443\&quot;" width="\&quot;550\&quot;">

You are not using onclick in your links are you? That simply is not allowed in html email.
These must be what your email client/service use as replacement. I don't believe geeklog would make those replacements.


Do you get the same result with other email services like gmail, yahoo, hotmail ...

I'll PM my test email and if you can have the newsletter plugin send me a copy.

-s


Re: Newsletter. Problem with links and images

Posted on: 26/01/11 08:50am
By: Pushkar

Quote by: suprsidr

<a onclick="return im_fixA(this);">link</a>

and
<a onclick="return im_fixA(this);" title="&quot;??????????" ????????????????="" ????????=""><img alt="&quot;&quot;" height="&quot;443&quot;" width="&quot;550&quot;">

You are not using onclick in your links are you? That simply is not allowed in html email.
These must be what your email client/service use as replacement. I don't believe geeklog would make those replacements.


Do you get the same result with other email services like gmail, yahoo, hotmail ...

I'll PM my test email and if you can have the newsletter plugin send me a copy.

-s



in gmail i get this:

PHP Formatted Code
<a>link</a>
<a title="\&quot;??????????"><img alt="\&quot;\&quot;" width="\&quot;550\&quot;" height="\&quot;443\&quot;"></a>


i was send you a newsletter

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 09:02am
By: suprsidr

in gmail i get this:

PHP Formatted Code
<a>link</a>
<a title="\&quot;??????????"><img alt="\&quot;\&quot;" width="\&quot;550\&quot;" height="\&quot;443\&quot;"></a>


And what exactly was the html in your newsletter that resulted in those examples?

-s

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 09:15am
By: suprsidr

Ok, I got the newsletter.

Lets make sure geeklog is not filtering your html as its very strange that the links set in the footer by the plugin do not get stripped.

Geeklog Admin -> Configuration -> Geeklog -> Miscellaneous -> HTML Filtering -> Skip HTML Filter for Root? -> Set to TRUE

-s

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 11:01am
By: Pushkar

Quote by: suprsidr

Ok, I got the newsletter.

Lets make sure geeklog is not filtering your html as its very strange that the links set in the footer by the plugin do not get stripped.

Geeklog Admin -> Configuration -> Geeklog -> Miscellaneous -> HTML Filtering -> Skip HTML Filter for Root? -> Set to TRUE

-s


Yes it is set to TRUE :banghead:

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 11:21am
By: suprsidr

I copied the html from your newsletter the way it displays on yoursite into my test site newsletter, and it sent fine - no stripping.

Don't use the advanced editor, and try again.

-s

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 03:05pm
By: Pushkar

Quote by: suprsidr

I copied the html from your newsletter the way it displays on yoursite into my test site newsletter, and it sent fine - no stripping.

Don't use the advanced editor, and try again.

-s


I try with html-mode - not helps Frown

Re: Newsletter. Problem with links and images

Posted on: 26/01/11 04:39pm
By: suprsidr

I don't think its an issue with the newsletter plugin.
The plugin is displaying your saved newsletter just fine.
I even test sent the same html from within my newsletter plugin no issue.(Pm me your email and I'll send to you as well)

So the issue has to be with the email services stripping what they have determined to be unsafe content.
Hotmail replaces your image with i_safe.gif so I believe the issue lies there.

-s

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 04:45pm
By: Pushkar

I have upgrade my geeklog site to 1.7.1 version, but plugin still not working Frown this problem was only in my case?

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 05:05pm
By: ::Ben

Hi. The newsletter plugin is working for me on a geeklog 1.7.1 site.

::Ben

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 05:10pm
By: Pushkar

Quote by: cordiste

Hi. The newsletter plugin is working for me on a geeklog 1.7.1 site.

::Ben


can you send me a link for download your newsletter plugin? maybe your version is newest than 1.0.8?

P.S. could it possible that the problem is in language of my site (russian)?

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 05:26pm
By: suprsidr

Sorry, 1.0.8 is the latest.

Does your geeklog use SMTP or PHP mail?

-s

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 05:33pm
By: Pushkar

Quote by: suprsidr

Sorry, 1.0.8 is the latest.

Does your geeklog use SMTP or PHP mail?

-s



I don't know. where I can check this?

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 05:45pm
By: suprsidr

If you don't know its most likely php mail
yoursite.com/admin/configuration.php -> Geeklog -> Site -> Mail -> Mail Settings[backend]

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 05:47pm
By: suprsidr

Forget my previous query, we can figure this out here.
go to yoursite.com/admin/mail.php
paste the contents of one of your newsletters there, and send it to yourself.
This cuts newsletter out of the equation.

-s

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 06:28pm
By: Pushkar

Quote by: suprsidr

Forget my previous query, we can figure this out here.
go to yoursite.com/admin/mail.php
paste the contents of one of your newsletters there, and send it to yourself.
This cuts newsletter out of the equation.

-s


I did it, and I received in a letter all links and images in right format. I think there is problem only in Newsletter plugin, maybe some settings

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 06:37pm
By: suprsidr

Newsletter uses phpmailer which has far more flexibility and an advanced feature set beyond php's mail function.
I'll update newsletter to the latest phpmailer.

-s

Re: Newsletter. Problem with links and images

Posted on: 07/02/11 08:53pm
By: suprsidr

Updated to phpmailer 5.1 give it a shot http://www.flashyourweb.com/filemgmt/index.php?id=19 and let me know.

-s

Re: Newsletter. Problem with links and images

Posted on: 08/02/11 01:23am
By: Pushkar

Quote by: suprsidr

Updated to phpmailer 5.1 give it a shot http://www.flashyourweb.com/filemgmt/index.php?id=19 and let me know.

-s



Thank you very much!!!! :banana: it's working correctly!

but I nave another problem: Subject of letter display in wrong charset :
PHP Formatted Code
Ïðîâåðêà Ðàçíûå èíòåðåñíûå øòó÷êè

Re: Newsletter. Problem with links and images

Posted on: 08/02/11 12:32pm
By: suprsidr

plugins/newsletter/functions.inc line 1362 add:
PHP Formatted Code
$mail->CharSet = $_CONF['default_charset'];

just after:
PHP Formatted Code
$mail = new PHPMailer(true);


-s

Re: Newsletter. Problem with links and images

Posted on: 08/02/11 02:38pm
By: Pushkar

Quote by: suprsidr

plugins/newsletter/functions.inc line 1362 add:

PHP Formatted Code
$mail->CharSet = $_CONF['default_charset'];

just after:
PHP Formatted Code
$mail = new PHPMailer(true);


-s


it's doesn't helps. this problem is only in subject and sender name of letter

Re: Newsletter. Problem with links and images

Posted on: 08/02/11 03:12pm
By: suprsidr

I don't know what to tell you. The newsletter plugin is not setting any charset anywhere.

That was my only thought.

Localization is my weak point, so maybe Ben or Dirk have an idea.

-s

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=91862