Subject: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 12:23am
By: Anonymous

So I have downloaded the new 1.6 file and unzipped it. I've uploaded all of the new files to the server and have overwritten all of the old files. I replaced db-config.php and siteconfig.php with my old files from 1.5. I then went to /admin/install/index.php. It was unable to find the db-config.php file so I typed in /var/www/Icode/db-config.php and pressed continue. I get to step 1 and choose upgrade. I get to step 2 and sucess! with reminders to delete admin/install and change security setting on siteconfig. So I did that... now is when problems arose...

Now when I go to my main domain I just get a blank page. IE says "done" loading in the status bar.

Where did I go wrong??? Any ideas?

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 02:53am
By: Dirk

Anything in your error.log? Or try activating the $_CONF['rootdebug'] option in your siteconfig.php

bye, Dirk

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 11:55am
By: Anonymous

Error log:

Sat Nov 28 17:33:09 2009 - Migration or upgrade for 'staticpages' plugin failed - plugin disabled
Sat Nov 28 17:33:09 2009 - Migration or upgrade for 'spamx' plugin failed - plugin disabled
Sat Nov 28 17:33:09 2009 - Migration or upgrade for 'links' plugin failed - plugin disabled
Sat Nov 28 17:33:09 2009 - Migration or upgrade for 'polls' plugin failed - plugin disabled
Sat Nov 28 17:33:09 2009 - Migration or upgrade for 'calendar' plugin failed - plugin disabled
Sat Nov 28 17:33:09 2009 - Attempting to install the 'xmlsitemap' plugin
Sat Nov 28 17:33:09 2009 - Attempting to add 'xmlsitemap' features
Sat Nov 28 17:33:09 2009 - Inserting default data
Sat Nov 28 17:33:09 2009 - Registering 'xmlsitemap' plugin
Sat Nov 28 17:33:09 2009 - Successfully installed the 'xmlsitemap' plugin!

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 12:05pm
By: Dirk

So, did you try activating $_CONF['rootdebug']?

bye, Dirk

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 12:12pm
By: Anonymous

Tried setting to 'force' nothing happened.

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 12:22pm
By: Dirk

Just checking: You did remove the // from the beginning of the line?

bye, Dirk

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 12:29pm
By: Anonymous

Yep. The // at the begining was deleted.

Re: Upgrade from 1.5 to 1.6

Posted on: 29/11/09 02:38pm
By: Dirk

Hmm. Without an error message it is of course hard to tell what's wrong.

What happens when you try to go to other parts of your site, like /search.php or /links/index.php?

If that also gives you blank pages, try the tips from the faq: Blank page

bye, Dirk

Re: Upgrade from 1.5 to 1.6

Posted on: 27/12/09 07:22pm
By: Anonymous

I have the same problem. Looks like the cause is Geeklog now requires Pear.

Make sure pear is installed on the server.



2 - require_once(HTTP/Request.php) [function.require-once]: failed to open stream: No such file or directory @ /home/www/system/classes/syndication/parserfactory.class.php line 31

// Require pear HTTP_REQUEST
require_once('HTTP/Request.php'Wink;

My question, any workaround for the issue? (besides installing Pear) Or should I just migrate back to 1.5

Re: Upgrade from 1.5 to 1.6

Posted on: 27/12/09 07:56pm
By: Anonymous

I commented out

require_once('HTTP/Request.php'Wink;

on line 31 of parserfactory.class.php and everything seems to work so far.
This is for those that do not run pear on you servers

Re: Upgrade from 1.5 to 1.6

Posted on: 28/12/09 03:38am
By: Dirk

Quote by: kgray

Looks like the cause is Geeklog now requires Pear.


Yes, Geeklog requires PEAR - since version 1.3.9. So this isn't exactly new ...

The required PEAR classes ship with Geeklog, in system/pear. If the config option "Have PEAR?" is set to False, those PEAR classes will be used. If set to True, the PEAR classes installed on the server will be used. So check that setting:

Configuration > Geeklog > Site > PEAR

bye, Dirk

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=89030