Subject: Changes are not saved

Posted on: 27/09/09 11:45am
By: Anonymous

Geeklog Community,

I just installed Geeklog 1.6.0sr2 on a Linux system with PHP 5.2.6, MySQL 4.1 and Apache 2.2. The PHP runs in CGI Mode. Register_Globals is ON. Permissions allow php script to write to files and directories.

The installation went fine. I deleted the install directory. I changed the Admin password.

When I try to change the inistal story, the changes aren't saved. There are not any error messages. The PHP logs and the Geeklog logs don't have any entries.

I had this same problem when I installed Geeklog 1.5.2sr4 and solved it. However, I don't remember what I did.

I removed enctype="multipart/form-data" from the file layout/professional/admin/story/storyeditor.thtml. it did not help.

What is the problem?

Jim

Re: Changes are not saved

Posted on: 27/09/09 11:54am
By: Dirk

Are you using the Professional theme or a custom theme? In the latter case, try switching to Professional and see if that helps.

bye, Dirk

P.S. register_globals = on is no longer required, at least not for Geeklog itself.

Re: Changes are not saved

Posted on: 27/09/09 12:09pm
By: Anonymous

Quote by: Dirk

Are you using the Professional theme or a custom theme? In the latter case, try switching to Professional and see if that helps.

bye, Dirk

P.S. register_globals = on is no longer required, at least not for Geeklog itself.



Thank you.

I'm using the default theme. The only layout theme is professional.

Jim

Re: Changes are not saved

Posted on: 27/09/09 12:19pm
By: Dirk

Referrers then, maybe? Our CSRF protection (since Geeklog 1.5.0) requires that referrers are enabled and correct.

See the latter half of this discussion (the 2009 posts - note that the first posts are from 2003 and out of date now).

bye, Dirk

Re: Changes are not saved

Posted on: 27/09/09 12:33pm
By: Anonymous

Quote by: Dirk

Referrers then, maybe? Our CSRF protection (since Geeklog 1.5.0) requires that referrers are enabled and correct.

See the latter half of this discussion (the 2009 posts - note that the first posts are from 2003 and out of date now).

bye, Dirk



I created the ref.php file at http://geeklog.uuism.org/ref.php

It reported Referrer: http://geeklog.uuism.org/ref.php

Thanks for the help.

Jim

Re: Changes are not saved

Posted on: 27/09/09 01:04pm
By: jimhermann

Quote by: jimhermann

Quote by: Dirk

Referrers then, maybe? Our CSRF protection (since Geeklog 1.5.0) requires that referrers are enabled and correct.

See the latter half of this discussion (the 2009 posts - note that the first posts are from 2003 and out of date now).

bye, Dirk



I created the ref.php file at http://geeklog.uuism.org/ref.php

It reported Referrer: http://geeklog.uuism.org/ref.php

Thanks for the help.

Jim



Also, I activated $_CONF['rootdebug'] = true;

Jim

Re: Changes are not saved

Posted on: 27/09/09 01:45pm
By: Dirk

Hmm, no immediate idea I'm afraid. Does this only affect stories or all of the admin panels (blocks, topics, static pages, ...)?

bye, Dirk

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=88532