Subject: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 01:14am
By: Anonymous

After following the upgrade instructions (http://www.geeklog.net/docs/install.html) I get this error: Fatal error: Cannot redeclare plugin_getmenuitems_links() (previously declared in /homepages/31/d94348771/htdocs/geeklog/plugins/links/functions.inc:79) in /homepages/31/d94348771/htdocs/geeklog/plugins/chameleon/functions.inc on line 77 I cannot find any information on this error. I've tried restoring the database and trying the upgrade again, but I get the same error message each time. I restored every config.php file in my installation. Any help is appreciated! Thanks, Nick

Re: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 03:51am
By: Robin

Hi Nick,

I've just gone through this upgrade Smile I haven't experienced such problems as you have however I think I can give you a tip on upgrading from 1.4.1 to 1.5.2 .

Before upgrading please change in config.php the default theme to professional and also in your admin account change this setting also to professional.

HTH,

Robert


Re: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 04:18am
By: Dirk

Quote by: Acoustix

Fatal error: Cannot redeclare plugin_getmenuitems_links() (previously declared in /homepages/31/d94348771/htdocs/geeklog/plugins/links/functions.inc:79) in /homepages/31/d94348771/htdocs/geeklog/plugins/chameleon/functions.inc on line 77


The error message suggests that it has something to do with the Chameleon plugin. So I'd suggest disabling / removing that plugin and try again.

bye, Dirk

Re: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 10:16am
By: Anonymous

Ok. I will try your suggestions and let you know what the results are.

Thanks!
-Nick

Re: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 10:23am
By: Anonymous

Ok - stupid question. I'm assuming that I will need to revert back to 1.4.1 in order to make the changes - correct?

-Nick

Re: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 10:32am
By: Dirk

I don't know much about the Chameleon plugin, but you could try disabling it in the database and see if the site comes back up.

bye, Dirk

Re: Error when upgrading from 1.4.1 to 1.5.2

Posted on: 17/03/09 04:01pm
By: Robin

Quote by: Acoustix

Ok - stupid question. I'm assuming that I will need to revert back to 1.4.1 in order to make the changes - correct?

-Nick



First of all, there are no stupid questions 8)

Let me have it straight. You copied the files and ran the upgrade procedure, right?

Now you can't access the site because of the error caused by Chameleon, right?

Do you have access to your database? If so try disabling the Chameleon there as Dirk suggested. This should help. If not we will investigate it further Big Grin

Robert

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=86686