Subject: bug in geeklog?

Posted on: 03/12/08 06:08pm
By: Mikez

I am working on a new site. 1.5.1 clean install.
After doing some testing, I can't get individual articles to come up.
Say like when you make a RSS feed and you click the link to a story in the feed.
It will just go to the front page. index.php.

I thought it may have been because I had Enable URL Rewrite.
So I turned it off.
Now when I go to the admin menu then stories and click the link that takes you to the story.(not edit)
I get An SQL error has occurred. Please see error.log for details.
But nothing is in the log.

How can I fix this? I have tried re-saving the story. But still nothing.
Also when I make new stories with URL Rewrite I am getting the sql error when trying to go to the individual articles.

please help!!! :helpme:

Re: bug in geeklog?

Posted on: 03/12/08 06:20pm
By: Mikez

sorry was loking at the wrong error log. Geeklol reads.
PHP Formatted Code
Wed Dec  3 15:15:27 2008 - 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE uid='2' AND sid='20081203150515184'' at line 1. SQL in question: SELECT COUNT(*) as cnt FROM  WHERE uid='2' AND sid='20081203150515184'
 


still don't know how to fix it.

Re: bug in geeklog?

Posted on: 04/12/08 02:54pm
By: Dirk

Hmm, I can't seem to find an SQL request like that in Geeklog 1.5.1. Could this be from some add-on that you installed?

Try disabling additional plugins and add-ons until the error goes away.

bye, Dirk

Re: bug in geeklog?

Posted on: 04/12/08 07:59pm
By: Mikez

It's a clean site. The only addon is Glmenu. I tried to make a new story with it off.
But still come up with the error. It's doing it on my test server also.

Re: bug in geeklog?

Posted on: 05/12/08 04:40am
By: Dirk

I checked the 1.5.1 source again and can't find anything in Geeklog that would use such an SQL request. This must be coming from some add-on.

bye, Dirk

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=85621