Subject: Delete polls

Posted on: 17/11/08 01:49am
By: Anonymous

I can not delete or edit polls help

Re: Delete polls

Posted on: 05/12/08 11:38am
By: Anonymous

I also got the same problem who can help us?

Re: Delete polls

Posted on: 05/12/08 02:56pm
By: Anonymous

same problem here but I haven't got a reply

default instalation and theme

Re: Delete polls

Posted on: 05/12/08 03:36pm
By: Dirk

I'm a bit baffled by these reports. I'll have to dig through the code over the weekend. Stay tuned ...

bye, Dirk

Re: Delete polls

Posted on: 05/12/08 05:23pm
By: Anonymous

every thing working fine for me. I am install by my self not fantastico auto install.

thanks

Re: Delete polls

Posted on: 05/12/08 07:54pm
By: Laugh

Does everything else work?

Re: Delete polls

Posted on: 06/12/08 05:52am
By: Dirk

To those with this problem, I forgot to ask: Anything in your error.log or access.log files that refers to the polls?

bye, Dirk

Re: Delete polls

Posted on: 06/12/08 06:17am
By: Anonymous

all logs show

*** dummy entry ***

Re: Delete polls

Posted on: 06/12/08 09:38am
By: Anonymous

I have been try

---new regitster.....work
---create ne poll.......work
---delete poll...........work
---user submition.....work
---story submition....work
---guest comment....work


Re: Delete polls

Posted on: 07/12/08 05:07am
By: 1000ideen

Quote by: steffcip

same problem here

It would be helpful if you gave a more detailed describtion. Xaviers says in another thread he is not using professional theme. Are you? What version of GL, and upgrades, manual install etc. etc. Confused: Confused: Confused: Confused:

Re: Delete polls

Posted on: 07/12/08 06:53am
By: Anonymous

I have given more details in another thread

standard install of this latest version
http://www.geeklog.net/filemgmt/viewcat.php?cid=8
standard theme (pro)
no extra add-ons or plugins
clean install

Re: Delete polls

Posted on: 07/12/08 08:54am
By: Dirk

steffcip, I sent you an email yesterday, asking if you could try something out for me. Did you get it?

bye, Dirk

Re: Delete polls

Posted on: 07/12/08 09:21am
By: Anonymous

no email
try send it again or use steff_cip at yahoo dot com

Re: Delete polls

Posted on: 07/12/08 09:49am
By: Anonymous

email sent Dirk

Re: Delete polls

Posted on: 07/12/08 04:48pm
By: Dirk

So it seems that, at least in steffcip's case, $_POST['mode'] is simply not set when the "delete" button is clicked. But at the same time, the almost identical code in the static pages plugin works as expected.

Very odd. Did we rule out browser differences yet?

bye, Dirk

Re: Delete polls

Posted on: 08/12/08 05:09am
By: Anonymous

at home I was only working in internet explorer 7
tried in firefox at work but same problem

Re: Delete polls

Posted on: 09/12/08 01:42pm
By: Anonymous

any idea Dirk?

want full access to site and ssh to account?

Re: Delete polls

Posted on: 09/12/08 03:51pm
By: Dirk

Quote by: steffcip

any idea Dirk?

want full access to site and ssh to account?


Out of ideas for the moment. I guess I would really have to debug it on a site where that problem occurs. So if you could give me access, that would be great. I won't have the time to really look into it before the weekend, though.

bye, Dirk

Re: Delete polls

Posted on: 12/12/08 12:28pm
By: Anonymous

Dirk
Email sent to you with all details (site, ftp, ssh)
If you could take a look this weekend that would be great
Thanks.

Re: Delete polls

Posted on: 13/12/08 03:43am
By: Dirk

So, on steffcip's server, all the form data is coming through just fine - only the $_POST['mode'] is missing?!

I notice that this server is running PHP as CGI and that it has the Suhosin patch installed. Does that match the configuration of anyone else who's experiencing this problem?

bye, Dirk

Re: Delete polls

Posted on: 13/12/08 04:57pm
By: jmucchiello

By default, suhosin only allows 200 post vars. The polls admin form easily blows that number away. You need to configure "post_vars = 1000" or more in the suhosin config file. Google for "suhosin post size" for additional details.

Re: Delete polls

Posted on: 13/12/08 06:38pm
By: Anonymous

will try changing that jmucchiello

Re: Delete polls

Posted on: 14/12/08 05:48am
By: Dirk

Quote by: jmucchiello

By default, suhosin only allows 200 post vars. The polls admin form easily blows that number away.


If that's the case, you could also reduce the "Max. Questions per Poll" and "Max. Options per Question" settings for the Polls.

Per default, they're 10 each, so that amounts to 300 post vars for the questions (including answers / votes / remarks) alone. Try 5 each.

bye, Dirk

Re: Delete polls

Posted on: 14/12/08 07:04am
By: Anonymous

set max questions per poll to 1 and max options per question to 6 and deleted the poll
thanks all for the help

Re: Delete polls

Posted on: 15/12/08 02:15pm
By: Dirk

Also see Polls Plugin vs. Suhosin.

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=85450