Subject: Weird Errors after migration

Posted on: 17/07/08 09:58am
By: nicholas

Help, I cant figure it out, can some kind soul pls help me? Oops!

I migrated my GL1.5 site from one server domain to another server domain. I carefully changed all my site-config, db-config and the config-values tables to the new domain but when I tried to access new site, I get these errors.

I suspect its due to the caching and I have cleared my browser but I don't know how to clear cache on server as I'm using cpanel from hosting provider. Where is all these cache data which I need to clear?

Could someone kindly advise if you have seen this same issue? Or pls advise how I can clear server cache to troubleshoot. Really appreciate it.

----------------------------------------------------------------------

Notice: unserialize() [function.unserialize]: Error at offset 2 of 40 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 2 of 46 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 57 of 57 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 37 of 37 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 42 of 42 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 46 of 46 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 45 of 45 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 42 of 42 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: unserialize() [function.unserialize]: Error at offset 44 of 44 bytes in /home/newsite/public_html/gl/system/classes/config.class.php on line 115

Notice: Undefined offset: 1 in /home/newsite/public_html/gl/system/lib-sessions.php on line 50

Notice: Undefined offset: 1 in /home/newsite/public_html/gl/system/lib-sessions.php on line 53

Warning: require_once(english_utf-8.php) [function.require-once]: failed to open stream: No such file or directory in /home/newsite/public_html/gl/lib-common.php on line 428

Fatal error: require_once() [function.require]: Failed opening required 'english_utf-8.php' (include_path='/home/oldsite/public_html/gl/system/pear/:.:/usr/lib/php:/usr/local/lib/php'Wink in /home/newsite/public_html/gl/lib-common.php on line 428

--------------------------------------------------------------------

Re: Weird Errors after migration

Posted on: 17/07/08 10:10am
By: Dirk

Quote by: nicholas

I migrated my GL1.5 site from one server domain to another server domain. I carefully changed all my site-config, db-config and the config-values tables to the new domain but when I tried to access new site, I get these errors.


So you edited the values in the gl_conf_values table manually? Note that they all include the length of an entry. So when you changed something from "foo" to "foobar" you would also have to add +3 to the string length.

From the error messages, I'd say you didn't do that (at all or not correctly) for some settings.

So double-check the entries you changed and correct the lengths accordingly.

And, yes, we really need a tool for that ...

bye, Dirk

Re: Weird Errors after migration

Posted on: 17/07/08 10:42am
By: nicholas

Gosh, this is the reason why GL is great, outstanding quick and clear response.

Thanks Dirk, sorry I missed a detail like that.

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=83832