Subject: Messed up my front page / no stories due to language

Posted on: 22/06/08 07:19am
By: phpsocialclub

I was messing around with the languages setting in the new 1.5 version of GL for a site that I upgraded from 1.4.1.

Some how all of of a sudden, I do not get any news on the home page (get the no news message) and the static pages do not show up there either.

After some digging, I found that this piece of sql was responsible "AND (s.tid LIKE '%\_en'Wink "

if I comment out line 243 in index.php , my articles come back on the front page

I know that none of my topics have "_en" in the title.

How do I undo this without recreating all my topics.

I have over 4000 stories in my site, so I would prefer to just remove the language option.

thanks,

Andrew

Re: Messed up my front page / no stories due to language

Posted on: 22/06/08 07:34am
By: Dirk

Yeah, we're missing a "disable" option to undo the "restore" ...

Try this:
PHP Formatted Code
UPDATE gl_conf_values SET value = 'unset' WHERE name = 'language_files';
UPDATE gl_conf_values SET value = 'unset' WHERE name = 'languages';

Note that in the second line it's 'languages' (plural).

bye, Dirk

Re: Messed up my front page / no stories due to language

Posted on: 22/06/08 08:06am
By: phpsocialclub

Dirk,

that did it,

thanks,

Andrew

Re: Messed up my front page / no stories due to language

Posted on: 23/06/08 10:46pm
By: nicholas

Hi,

I encountered the same issue of no stories displayed while testing the multilanguage in config. Took me a full day before I found this foum posting.

Is there any permanent fix for this in GL1.5 so that I can still use the multi-lang config for "languages"?

Appreciate any info.

Thanks
Nicholas

Re: Messed up my front page / no stories due to language

Posted on: 24/06/08 01:50am
By: Dirk

Quote by: nicholas

Is there any permanent fix for this in GL1.5 so that I can still use the multi-lang config for "languages"?


Not sure what you mean. The multi-language support works as expected (and as it did in 1.4.1). It's only when you accidentally enable it (like above), there's no way to disable it again. We're going to address that in the next release.

Keep in mind that if you want to use the multi-language capabilities, then all your stories and topics must exist with a language suffix. If you don't have that, no stories will be displayed.

See the wiki article for details.

bye, Dirk

Re: Messed up my front page / no stories due to language

Posted on: 24/06/08 05:05am
By: nicholas

Thanks Dirk,

Sorry I wasn't clear. Yes, I am aware of the suffix, just to explain reason why I still asked. I am currently running GL1.4.1 with multi-languages set in my config file and I could display all my stories in different languages without the language suffix. But with GL1.5, nothing shows without the suffix, hence I was hoping that stories without suffix can still show if a permissible modification allows so? There are many occasions I have multilanguages within one story/page.

Re: Messed up my front page / no stories due to language

Posted on: 25/06/08 03:25pm
By: Dirk

Quote by: nicholas

I am currently running GL1.4.1 with multi-languages set in my config file and I could display all my stories in different languages without the language suffix. But with GL1.5, nothing shows without the suffix


Hmm, I don't think anything has really changed there. In fact, I'm wondering how it should have worked that way in 1.4.1.

You can have stories without the suffix in 1.4.1, but they will only show up in their topic, not on the index page.

bye, Dirk

Re: Messed up my front page / no stories due to language

Posted on: 25/06/08 08:29pm
By: nicholas

Thanks Dirk, I really appreciate your prompt response. GL is a good software anyway regardless.

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=83326