Subject: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 01/11/07 06:30pm
By: pinkponk

How it to correct?

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 01/11/07 10:12pm
By: suprsidr

what part in english?

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 10:17am
By: pinkponk

Quote by: suprsidr

what part in english?


Everything, except for the name of albums
look http://begimot.ru/foto http://begimot.ru/geeklog

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 10:23am
By: suprsidr

tell me if this should be different
PHP Formatted Code
$GL_to_G2_language = array(
        //      'bosnian'                       =>      'xx',   // *** No mapping
                'bulgarian'                     =>      'bg',
                'chinese_big5'          =>      'zh',
                'chinese_gb2312'        =>      'zh',
                'chinese_simplified_utf-8'      =>      'zh_TW',
                'chinese_traditional_utf-8'     =>      'zh',
        //      'croatian_utf-8'        =>      'xx',   // *** No mapping
        //      'croatian'                      =>      'xx',   // *** No mapping
                'czech'                         =>      'cs',
                'danish'                        =>      'da',
                'dutch'                         =>      'nl',
                'english_utf-8'         =>      'en_GB',
                'english'                       =>      'en_GB',
                'finnish_utf-8'         =>      'fi',
                'finnish'                       =>      'fi',
                'french_canada'         =>      'fr',
                'french_france'         =>      'fr',
                'german_formal'         =>      'de',
                'german_utf-8'          =>      'de',
                'german'                        =>      'de',
                'hebrew'                        =>      'he',
                'hellenic'                      =>      'el',
        //      'indonesian'            =>      'xx',   // *** No mapping
                'italian'                       =>      'it',
                'japanese_utf-8'        =>      'ja',
                'japanese'                      =>      'ja',
                'norwegian'                     =>      'no',
                'polish'                        =>      'pl',
                'portuguese_brazil'     =>      'pt_BR',
                'portuguese'            =>      'pt_PT',
        //      'romanian'                      =>      'xx',   // *** No mapping
                'russian'                       =>      'ru',
        //      'slovak'                        =>      'xx',   // *** No mapping
                'slovenian'                     =>      'sl',
                'spanish_argentina'     =>      'es',
                'spanish'                       =>      'es',
                'swedish'                       =>      'sv',
                'turkish'                       =>      'tr'
                );
 

I'm no language expert.

-s

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 10:41am
By: pinkponk

Quote by: suprsidr

tell me if this should be different

PHP Formatted Code
$GL_to_G2_language = array(
        //      'bosnian'                       =>      'xx',   // *** No mapping
                'bulgarian'                     =>      'bg',
                'chinese_big5'          =>      'zh',
                'chinese_gb2312'        =>      'zh',
                'chinese_simplified_utf-8'      =>      'zh_TW',
                'chinese_traditional_utf-8'     =>      'zh',
        //      'croatian_utf-8'        =>      'xx',   // *** No mapping
        //      'croatian'                      =>      'xx',   // *** No mapping
                'czech'                         =>      'cs',
                'danish'                        =>      'da',
                'dutch'                         =>      'nl',
                'english_utf-8'         =>      'en_GB',
                'english'                       =>      'en_GB',
                'finnish_utf-8'         =>      'fi',
                'finnish'                       =>      'fi',
                'french_canada'         =>      'fr',
                'french_france'         =>      'fr',
                'german_formal'         =>      'de',
                'german_utf-8'          =>      'de',
                'german'                        =>      'de',
                'hebrew'                        =>      'he',
                'hellenic'                      =>      'el',
        //      'indonesian'            =>      'xx',   // *** No mapping
                'italian'                       =>      'it',
                'japanese_utf-8'        =>      'ja',
                'japanese'                      =>      'ja',
                'norwegian'                     =>      'no',
                'polish'                        =>      'pl',
                'portuguese_brazil'     =>      'pt_BR',
                'portuguese'            =>      'pt_PT',
        //      'romanian'                      =>      'xx',   // *** No mapping
                'russian'                       =>      'ru',
        //      'slovak'                        =>      'xx',   // *** No mapping
                'slovenian'                     =>      'sl',
                'spanish_argentina'     =>      'es',
                'spanish'                       =>      'es',
                'swedish'                       =>      'sv',
                'turkish'                       =>      'tr'
                );
 

I'm no language expert.

-s



It in what file? I use russian_utf-8

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 10:56am
By: suprsidr

plugins/G2Bridge/functions.inc

~line 590

please post back any corrections you make.

-s

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 11:06am
By: pinkponk

Quote by: suprsidr

plugins/G2Bridge/functions.inc

~line 590

please post back any corrections you make.

-s


$lang = 'ru'; // default to English
it working, thanks
how about g2image?

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 11:12am
By: suprsidr

in our last communication about g2Image, you did not even know how/what fckeditor was. I don't know what to tell you besides learn how to use your site's software before trying advanced settings.

-s

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 11:24am
By: pinkponk

Quote by: suprsidr

in our last communication about g2Image, you did not even know how/what fckeditor was. I don't know what to tell you besides learn how to use your site's software before trying advanced settings.

-s


fckeditor works, g2image it is established, but does not work

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 11:39am
By: suprsidr

this will be the only time I do this, so if you need to re-read or re-translate this please do so on your own.

upload fckconfig.js and myconfig.js to:
/home2/pinkponk/public_html/geeklog/fckeditor/

upload the G2Image directory and all of its contents to:
/home2/pinkponk/public_html/geeklog/fckeditor/editor/plugins/


no other configuration is necessary, that means you do not need to edit any config files.
I have added G2Image to toolbar2 and toolbar3 for you.

Clear your browser's cache and you should see the G2Image button in fckeditor using toolbar2 or toolbar3.
If you do not, redo all steps from above.

-s

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 12:19pm
By: pinkponk

Quote by: suprsidr

this will be the only time I do this, so if you need to re-read or re-translate this please do so on your own.

upload fckconfig.js and myconfig.js to:
/home2/pinkponk/public_html/geeklog/fckeditor/

upload the G2Image directory and all of its contents to:
/home2/pinkponk/public_html/geeklog/fckeditor/editor/plugins/


no other configuration is necessary, that means you do not need to edit any config files.
I have added G2Image to toolbar2 and toolbar3 for you.

Clear your browser's cache and you should see the G2Image button in fckeditor using toolbar2 or toolbar3.
If you do not, redo all steps from above.

-s


is it necessary to change anything here?
if (file_exists('../../../../lib-common.php'Wink) // we have geeklog
{
require_once ('../../../../lib-common.php'Wink;
}
$g2ic_gallery2_path = $_G2B_CONF['G2_path']."/";

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 04:50pm
By: pinkponk

An error has occurred:
2 - file_exists() [function.file-exists]: open_basedir restriction in effect. File(../../../../../../../wp-config.php) is not within the allowed path(s): (/home2/pinkponk:/usr/lib/php:/usr/local/lib/php:/tmp) @ /home2/pinkponk/public_html/geeklog/fckeditor/editor/plugins/G2Image/init.php line 50

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 05:05pm
By: suprsidr

must be open_basedir problem, you can remove that whole block of code lines 48 - 107

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 05:33pm
By: pinkponk

Quote by: suprsidr

must be open_basedir problem, you can remove that whole block of code lines 48 - 107



What exactly and where to remove?

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 05:39pm
By: suprsidr

you can remove that whole block of code lines 48 - 107


/home2/pinkponk/public_html/geeklog/fckeditor/editor/plugins/G2Image/init.php

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 07:14pm
By: pinkponk

Quote by: suprsidr

you can remove that whole block of code lines 48 - 107


/home2/pinkponk/public_html/geeklog/fckeditor/editor/plugins/G2Image/init.php


g2image Was gone

Unknown element of the panel of tools "tagging"

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 07:24pm
By: pinkponk

Quote by: pinkponk

Quote by: suprsidr

you can remove that whole block of code lines 48 - 107


/home2/pinkponk/public_html/geeklog/fckeditor/editor/plugins/G2Image/init.php


g2image Was gone

Unknown element of the panel of tools "tagging"


I have understood
thank you very much

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 07:48pm
By: suprsidr

delete anywhere in myconfig.js you see ,'Tagging'

-s

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 02/11/07 08:04pm
By: pinkponk

Quote by: suprsidr

delete anywhere in myconfig.js you see ,'Tagging'

-s


I have a 2 quastions

Why dates look so? on �������, ������ 03 2007 @ 02:25 MSK
How to make such pictures? http://www.gllabs.org/vthemes/index.php

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 01:48pm
By: pinkponk

Quote by: pinkponk

Quote by: suprsidr

delete anywhere in myconfig.js you see ,'Tagging'

-s


I have a 2 quastions

Why dates look so? on �������, ������ 03 2007 @ 02:25 MSK
How to make such pictures? http://www.gllabs.org/vthemes/index.php




How to clean links to pictures in clause?
http://begimot.ru/geeklog/article.php?story=20071103022526716

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 05:57pm
By: pinkponk

Has put
$_CONF['language'] = 'russian_utf-8';
$_CONF['default_charset'] = 'utf-8';

geeklog text is ok
gallery text is ok
but my rss is abrakadabra

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 06:13pm
By: suprsidr

gallery->admin->general->cookies

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 06:46pm
By: pinkponk

Quote by: suprsidr

gallery->admin->general->cookies


what do I write there?

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 07:09pm
By: suprsidr

PATH /
DOMAIN .begimot.ru

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 07:18pm
By: pinkponk

Quote by: suprsidr

PATH /
DOMAIN .begimot.ru


Again abracadabra

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 07:23pm
By: suprsidr

don't you read instructions?

Once you change the cookie settings, all registered users of your Gallery will have to clear their browser cookie cache. If they do not, they will experience login / logout / lost session problems.

Re: My gallery in Russian, but g2bridge shows gallery on english

Posted on: 03/11/07 07:39pm
By: pinkponk

Quote by: suprsidr

don't you read instructions?

Once you change the cookie settings, all registered users of your Gallery will have to clear their browser cookie cache. If they do not, they will experience login / logout / lost session problems.



I do not have registration in galleries ?
Unless the text rss depends on users?

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=79493