Subject: No "Delete" button in static page editor.

Posted on: 04/06/07 05:42am
By: appie252001

How can you remove a static page, there is no "Delete" button anymore at the bottom of the static page editor?

In the story editor there is, so that's working fine.

Thanks.

Albert

Re: No "Delete" button in static page editor.

Posted on: 04/06/07 12:01pm
By: Laugh

There should be a delete button by the cancel button when you open a staticpage for editing.

Are you using a different theme (not the Professional one)? If so make sure you have updated the admin template files in your themes directiory.


Re: No "Delete" button in static page editor.

Posted on: 04/06/07 12:16pm
By: appie252001

Laugh,

There is only a save (Opslaan) and cancel (Annuleren) button on this page?

I'm using the default Professional theme.

I can't add a screen print, ontherwise I could show you.

Albert


Re: No "Delete" button in static page editor.

Posted on: 04/06/07 12:33pm
By: Laugh

Are you using Geeklog 1.4.1 (latest version)?


Also try switching your site to english to see if that may be causing the issue.




Re: No "Delete" button in static page editor.

Posted on: 04/06/07 01:49pm
By: Dirk

There is no delete button when you create a new static page (since there's nothing to delete before you have saved the page). Other than that, try what Laugh said.

bye, Dirk

Re: No "Delete" button in static page editor.

Posted on: 04/06/07 02:00pm
By: appie252001

Dirk, Laugh,

I changed to English, but still no delete button. I'm using the latest version of Geeklog (1.4.1).

I'm talking about already existing pages, but I made a new one, just to try if the button is showing after saving the page. Also then, no delete button.

I can send you the page if you need to?

Albert


Re: No "Delete" button in static page editor.

Posted on: 04/06/07 03:21pm
By: Dirk

Is this after an upgrade from an earlier version? If so, please double-check that you've really updated all the files of the static pages plugin.

bye, Dirk

Re: No "Delete" button in static page editor.

Posted on: 05/06/07 02:14pm
By: appie252001

Dirk,

This is after an update from an earlier version. I just uploaded all the files agian for the staticpage in admin, site and plugin. No change, still no delete button.

I see that there is an install file for the staticpage, should I run that one?

I only did run the install file of geeklog when upgrading the site?

Albert

Re: No "Delete" button in static page editor.

Posted on: 05/06/07 03:14pm
By: Dirk

The static pages plugin is updated with the rest of the database when you run the install script in upgrade mode - no need for any additional steps.

Check that you have the 'staticpages.delete' permission: Edit the "Static Page Admin" group and make sure that permission is checked.

bye, Dirk

Re: No "Delete" button in static page editor.

Posted on: 06/06/07 01:13pm
By: appie252001

Dirk,

Problem solved, there was no Static Page Admin at all? I created one, and set the right permissions, and now te delete button is showing.

I think, I have a simmular right problem with adding an event by any users. Can you tell what rights should be set on what place, to alow logged in users and not logged in users to add a new event in the calendar?
http://www.geeklog.net/forum/viewtopic.php?showtopic=76592

Thanks.....

Albert

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=76721