Subject: reinstall with existing database - help needed please

Posted on: 02/06/07 06:45am
By: ronsteenvoorden

Hello everyone,

During my holiday my geeklog installation was hacked. A friend updated the installation from 1.40sr5 to 1.41 but that didn't help. After that the provider removed everything and made me promise not to restore everything. The database is still there however.

My question is now: how do i (re)install the latest version 1.41 with the existing database where all my stories and other stuff are still in?

Many thanks for your response! Smile

Re: reinstall with existing database - help needed please

Posted on: 02/06/07 06:58am
By: Dirk

Just upload the files, set the paths and call up your site, i.e. follow every step in the installation instructions with the exception of actually running the install script.

bye, Dirk

Re: reinstall with existing database - help needed please

Posted on: 02/06/07 09:12am
By: ronsteenvoorden

Many thanks Dirk,

I have done everything you said... In my previous (unsecure) installation I had all the directories in the public_html root and now I have made a special directory password protected for the directories that don't belong in the public_html root. I have however a problem with the following: I had mediagallery installed under /public_html/plugins/mediagallery.

In the new installation the path is /public_html/overig/plugins/mediagallery and I now receive the following error on the blog:

An error has occurred:
2 - main(/home/*****/public_html/blog/overig/mediagallery/common.php) [function.main]: failed to open stream: No such file or directory @ /home/acjdcxa/public_html/blog/overig/plugins/mediagallery/functions.inc line 49

Geeklog is apparantly still looking for the plugin but can't find it in the directory where it used to be. Is there a way to modify a setting somwhere? Maybe in the database?

many thanks!

Re: reinstall with existing database - help needed please

Posted on: 02/06/07 09:26am
By: Dirk

Sounds more like something you'd have to adjust in the config of MediaGallery. Geeklog itself only keeps track of the names of plugins, not of their paths.

bye, Dirk

Re: reinstall with existing database - help needed please

Posted on: 02/06/07 09:32am
By: ronsteenvoorden

I have checked and the paths of MG are good. I have found two paths in the MG database, but I have to contact someone from mediagallery and ask if and how I can update these.

Do you know if i can test and run geeklog temporarily without the mediagallery plugin? Maybe disable it somewhere? Right now i cannot access geeklog or the admin panel at all....

thanks again Smile

Re: reinstall with existing database - help needed please

Posted on: 02/06/07 10:07am
By: Dirk

Go into the database (using phpMyAdmin or whatever's handy). Find the entry for MediaGallery in table gl_plugins and set pi_enabled to 0 (from 1). That will disable the plugin and you can enable it from Geeklog's plugin admin panel later on.

bye, Dirk

Re: reinstall with existing database - help needed please

Posted on: 03/06/07 05:31am
By: ronsteenvoorden

Hi Dirk,

Many thanks for your help. I'm up and running again and will sort out the mediagallery restore with Mark! Smile

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=76669