Subject: G2Bridge support

Posted on: 19/03/06 11:07am
By: suprsidr

G2Bridge for Gallery 2.1 has been released.


Formerly GL_Gallery2 this version has been fully updated to take advantage of the all new Gallery 2.1 API.


Note: This version does not work with Gallery 2.0.x Only with 2.1 or greater.



You can get this fabulous plugin here. And support can be found on my site here, and geeklog right here.


G2Bridge support

Posted on: 24/03/06 06:45am
By: suprsidr

Hey, Gallery 2.1 has officially been released

get it here.

and while your at it, pick up a copy of our bridge.


G2Bridge support

Posted on: 24/03/06 02:41pm
By: wikki

integration didn't work out for me. whenever i try to deinstall the old plugin, it just shows me a white page (the same if i use the new functions.inc). if i use the extra functions.inc that is supposed to be used for the deinstallation, it doesn't do anything.
after deleting the plugin manually from the plugins table and starting from scratch, it runs the installation but points to /admin/plugins/G2Bridge/install/
this folder doesn't exist though. if i point to install.php i get
Fatal error: Call to undefined function: plugin_chkversion_g2bridge() in /var/www/vhosts/pfuy.de/httpdocs/admin/plugins/G2Bridge/install.php on line 48


using GL 1.4.0sr2
Gallery2.1.0

G2Bridge support

Posted on: 24/03/06 05:29pm
By: suprsidr

Which version of GL_Gallery2 were you using?
The functions_upgrade_to_G2Bridge.inc was copied directly from GL_Gallery2 v.0.5.0, with just the function to remove users from Gallery disabled.

What does your error.log say?


as for the undefined function, make sure the normal G2Bridge functions.inc is in path_to_geeklog/plugins/G2Bridge/

If you removed the plugin manually, I don't see any problem simply installing G2Bridge.

Hope this helps

G2Bridge support

Posted on: 02/04/06 12:59pm
By: Anonymous

I am receiving a simmilar error:


Fatal error: Call to a member function on a non-object in /home/julianna/plugins/G2Bridge/functions.inc on line 689


The last line in my error.log file is:


Mapping users from GL into G2


The plugin seems to have partially installed, but when I go to the Gallery2 config from the GL admin menu, I receive the following:


username: [Julianna]
fullname: [Julianna Yau]
hashedpassword: [*removed for security*]
email: [*removed for anti-spam*]
creationtimestamp: [1058386020]

Failed to create G2 user with extId [4 - 4] Here is the error message from G2:
Error (ERROR_COLLISION)

* in modules/core/classes/GalleryUser.class at line 154 (gallerycoreapi::error)
* in modules/core/classes/GalleryEmbed.class at line 360 (galleryuser::create)
* in /home/julianna/plugins/G2Bridge/functions.inc at line 585 (galleryembed::createuser)
* in /home/julianna/public_html/sculpture_gallery/index.php at line 59


I am using Gallery 2.1

I took a look at functions.inc, and found this line at 690:


$res = GalleryCoreApi::addUserToGroup( $G2_uid, 3); //G2 admin groupid is 3


I do not have a user with the ID of 3. Could this be creating the problem?

Thanks.

Julianna

G2Bridge support

Posted on: 02/04/06 01:07pm
By: suprsidr

The problem is caused when you are trying to add(map) a user from geeklog to gallery that already exsists in gallery.

try a couple of the techniques in this thread here.

and the 3 is the admin groupid in gallery that we were trying to add you to.

G2Bridge support

Posted on: 05/04/06 10:51pm
By: suprsidr

G2Bridge v1.1 now available.


v1.1 [5 Apr 2006]


o [new] Added option for displaying left and right blocks in config.php
o [fix] Now correctly maps users that pre-exsist in both apps, no more collisions.
o [fix] Gallery2 sidebar now displays properly.


You can get the update here. And support can be found on my site here.

G2Bridge support

Posted on: 08/04/06 08:32pm
By: suprsidr

Hey All, I've just released G2Image Chooser for G2Bridge.

This plugin for FCKeditor lets you browse and add images from your gallery directly into your stories!

How cool is that?

Get it here.

and support can be found here.


G2Bridge support

Posted on: 28/05/06 05:28pm
By: Anonymous

Thanks a lot for your hard work!

Just a small remark: I noticed that the Random Photo block seems to take up quite a lot of CPU time, any thoughts on reducing this? Maybe it would be possible to limit the random photo's to the last album or something.

G2Bridge support

Posted on: 05/10/06 12:28pm
By: Anonymous

Hi,

I tried to install this plugin (G2Bridge1.1_current.zip) but I also just get a blank screen after clicking "install".

I am using Gallery 2.1.1 with GL 1.4.0sr5-1.

My G2 install is at public_html/g2 and my GL is at public_html/gl.

Below is part of the plugins config.php:

$_G2B_CONF['public_dir'] = 'G2Bridge';

/* I think with Gallery 2.1 we have finally done away with the path confusion. I have set these to the default with gallery2 in your public_html directory.
    You should only need to change these IF gallery2 is NOT in your public_html directory.
*/

$_G2B_CONF['G2_path'] = $_CONF['path_html'].'/g2'; // full system path to your gallery2 install no trailing /

$_G2B_CONF['embedUri'] = $_CONF['site_url'].'/'.$_G2B_CONF['public_dir'].'/index.php?';   // full url to your G2Bridge index.php with trailing ? 

$_G2B_CONF['g2Uri'] = $_CONF['site_url'].'/g2/';  // full url to you gallery2 with trailing /


error log stops at "Mapping users from GL into G2"

Sorry I tried to create an account at the support site but it didn't work.

Thanks in advance,

PlaygroundPeople


G2Bridge support

Posted on: 05/10/06 04:28pm
By: suprsidr

it seems your paths are not quite right .

you should try full system path ie.
$_G2B_CONF['G2_path'] =' /usr/home/local/htdocs/public_html/g2';

if both gl and g2 are in public_html, $_CONF['path_html'] would not work.

Hope this helps.

-s

Re: G2Bridge support

Posted on: 07/04/07 07:39pm
By: Anonymous

My question concerns the sidebar image block clutter. It seems as though having it replicate the image blocks is pointless as when you click on the gallery it looks awful with them replicated right next to each other.

Re: G2Bridge support

Posted on: 07/04/07 09:16pm
By: suprsidr

So was there a question?

Re: G2Bridge support

Posted on: 07/04/07 11:50pm
By: Anonymous

Is there a way to have the image block function of the bridge be useful? If you have to have the blocks showing in your gallery it makes them showing in geek log sort of redundant. Is there a way to add the set of blocks without having them showing in gallery?


Re: G2Bridge support

Posted on: 08/04/07 12:24am
By: suprsidr

Sure.
in public_html/G2Bridge/index.php

around line 88 just before:
PHP Formatted Code
$g2data = GalleryEmbed::handleRequest();

add:
PHP Formatted Code
$gallery->setConfig('showSidebarBlocks', false);

this tells gallery not to show its sidebarblocks.


-s

Re: G2Bridge support

Posted on: 08/04/07 12:32am
By: greenteagod

Beautiful, was that something I missed in the readme? I've come across a few other forums where people were looking for this exact thing. I guess they didn't make it to the actual geeklog page. Definitely a setting you'd want to add to the file, unless it was already there and I was too daft to catch it. Either way, thank you very much.

One more thing if you have a moment. Is it possible to edit the heading of the blocks. Right now it just says Gallery2. If I could change that to a linked image it would suit my tastes a bit better, though if this isn't possible I understand. Thanks.

Re: G2Bridge support

Posted on: 08/04/07 08:22am
By: suprsidr

The block title is inserted into the db and geeklog does not support html for block titles
But there is a way to use images for block titles.

in public_html/layout/yourtheme/blockheader-left.thtml
geeklog calls the title here:
PHP Formatted Code
<h2>{block_title}</h2>

and I've been known to use this instead:
PHP Formatted Code
<img title="{block_title}" alt="{block_title}" src="{layout_url}/images/{block_title}.gif" />

Although at this point all block titles will be replaced with images(.gif) of the same exact name.

Beautiful, was that something I missed in the readme?

No, but it was in my forums on mysite prior to my moving it.
And I did not move all the old forums with it sorry.

Also I should get off my but and release an update as there are a couple of minor changes since Gallery 2.2 and GL 1.4.1

-s

Re: G2Bridge support

Posted on: 15/06/07 11:16pm
By: Anonymous

1) I want the block to appear at a specific image size with the HTML title correctly appearing instead of <a href="">A sample photograph</a> on display at the museum should appear as A Sample Photograph on display at the museum.

2) Furthermore, it would be helpful if the block appeared on the footer independently from the right/left blocks is this possible?

3) How do I set the block NOT to link to the gallery image URL and just be graphically imbedded?

Re: G2Bridge support

Posted on: 15/06/07 11:30pm
By: suprsidr

There are some config options for random photo block in path_to_geeklog/plugins/G2Bridge/config.php
and more info can be found in your gallery admin->image block

Also I have made a flash-based mini slideshow which you are welcome to.

-s

Re: G2Bridge support

Posted on: 16/06/07 09:46am
By: Anonymous



In the G2Bridge block, I want to edit the layout and HTML size of the Times New Roman text which does not match my CSS. I can't find which file to edit that will make minor adjustments to the way the image block appears - i.e. spacing, fonts...

Also, is there not a way to place the image block in the footer rather than block?

Re: G2Bridge support

Posted on: 16/06/07 04:48pm
By: suprsidr

There is no template file specifically for the random photo, we simply build a block and fill it.
but if you may, the block function is in plugins/G2Bridge/functions.inc
function phpblock_G2B_rand_photo()

Geeklog does not allow for php in the footer, but you could create a staticpage, enable php execution, and set the contents to:
PHP Formatted Code

echo phpblock_G2B_rand_photo();
 

and make this a centerblock at the bottom of the page

-s

Re: G2Bridge support

Posted on: 22/07/07 05:20pm
By: greenteagod

New bit of a boggle here. I recently moved my blocks from left to right, and now am getting a message stating "You need to enable sidebar blocks in your Gallery 2 theme configuration." When I am actually viewing the rest of the gallery these blocks show up correctly.

www.super-crush.com

Re: G2Bridge support

Posted on: 23/07/07 07:26pm
By: suprsidr

Funny, I was just working on a new version, to fix the new way GL checks for anonymous users.
I'll look into that tonight also and get back to you.

-s

Re: G2Bridge support

Posted on: 29/07/07 01:41am
By: greenteagod

Any luck on it? Sort of odd behavior =D

Re: G2Bridge support

Posted on: 02/08/07 10:48pm
By: suprsidr

I'm sorry, not sure why I no longer get notified of responses to this forum Exclamation

I believe I have it licked, as well as some other minor adjustments.

If you could give it a try and let me know.
http://www.flashyourweb.com/filemgmt/index.php?id=8

Thanks
-s

Re: G2Bridge support

Posted on: 03/08/07 10:51pm
By: greenteagod

Editing my previous post. The blocks do work, but for some reason they only jump to the photo when you are logged in. When not logged in clicking a photo takes you back to the main gallery page. Perhaps a setting I missed in the custom.php?

Re: G2Bridge support

Posted on: 06/08/07 08:37pm
By: suprsidr

I've just released v.2.0 of the G2Bridge plugin.
I've added the ability to display my XML MiniSlideShow in a block via the G2Bridge admin, very cool Smile

get it here.

Please give it a try and lt me know what you think.

-s

Re: G2Bridge support

Posted on: 08/08/07 05:20pm
By: greenteagod

Excellent excellent. I did notice though that setting it "centered" still looks like it's set to the left. Also I was wondering if it would be possible to have a fade transition that simply faded into another photo instead of fading all the way out and fading back in, if you get my meaning.

Re: G2Bridge support

Posted on: 08/08/07 07:30pm
By: suprsidr

Actually, I have a version like that which has no loader component, and better transitions.
But alas I've had little time to work on it of late.

We are about to release a transcode module to convert (most) any video to flashvideo from within Gallery2.

That coupled with our XML Media Player should be an awesome combination.

But I'll keep you updated Smile

-s


Re: G2Bridge support

Posted on: 07/09/07 10:21am
By: falkon

Just trying out Geeklog again after a long layoff. Love the usability of the new 1.4.1 version. I also have Gallery 2.2.2 installed. I just installed the new G2Bridge 2.0 plugin. The plugin created the blocks as expected. However, I also expected it to wrap the the gallery page. Is this not the case? If not, is there a quick and easy way to wrap Gallery 2 inside of Geeklog 1.4.1?

Thanks in advance,

Richard

Re: G2Bridge support

Posted on: 07/09/07 04:54pm
By: suprsidr

the uri to gallery via the bridge should be yoursite.com/G2Bridge/index.php

you can change whether or not left and right blocks appear and some other options in the path_to_geeklog/plugins/G2Bridge/config.php

-s

Re: G2Bridge support

Posted on: 07/09/07 07:42pm
By: falkon

Thanks! Now, going direct to that url I see my gallery nicely wrapped. However, when I click on a random image in a block I get this error: The requested URL /G2Bridge/v/test/blockt_md.jpg.html was not found on this server.

Also, when I log off as a user I get this error: Fatal error: Undefined class name 'galleryembed' in /home/knoxqbcl/public_html/plugins/G2Bridge/functions.inc on line 149

My gallery is installed in a folder called "gallery". Here are my path entries in /plugins/G2Bridge/config.php:

*/
$_G2B_CONF['public_dir'] = 'G2Bridge';

/* I think with Gallery 2.1 we have finally done away with the path confusion. I have set these to the default with gallery2 in your public_html directory.
You should only need to change these IF gallery2 is NOT in your public_html directory.
*/

$_G2B_CONF['G2_path'] = $_CONF['path_html'].'/gallery'; // full system path to your gallery2 install no trailing /

$_G2B_CONF['embedUri'] = $_CONF['site_url'].'/'.$_G2B_CONF['public_dir'].'/index.php'; // full url to your G2Bridge or public_dir index.php

$_G2B_CONF['g2Uri'] = $_CONF['site_url'].'/gallery/'; // full url to you gallery2 with trailing /

Thanks again for your help,

Richard

Re: G2Bridge support

Posted on: 07/09/07 08:13pm
By: suprsidr

the logout problem - Sorry I need to get the fixed version up on geeklog.net:
functions.inc line ~147
PHP Formatted Code
function plugin_user_logout_G2Bridge( $uid )
{
    G2B_G2_init();
        GalleryEmbed::logout( array('embedPath' => $_G2B_CONF['embedUri']) );
}


need to call the init function.

as for the urlrewrite.
Quote from admin/readme.html
# If you have G2's URL Rewrite module installed, deactivate and remove it. Re-install it through the embedded version after you've completed the installation of the plugin and verified that the installation works properly. This will ensure that the correct paths are used for rewriting.


-s

Re: G2Bridge support

Posted on: 07/09/07 08:53pm
By: falkon

That did it, thanks!

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=65402