Subject: filemgmt how to change icons

Posted on: 02/03/06 10:14am
By: donm1021

I am using the filemgmt plugin, and the site I am creating will allow uploads of word docs, excel files, and powerpoint.

I would like to offer the corresponding icon for each application instead of the disk looking icon - does anyone know how to change that icon?

Thanks!


filemgmt how to change icons

Posted on: 04/03/06 04:30am
By: Dirk

You could simply replace the images/download.gif

The code that creates the entry for a downloadable file is in include/dlformat.php (both in the public filemgmt directory).

bye, Dirk

filemgmt how to change icons

Posted on: 04/03/06 07:10am
By: donm1021

Yeah, I thought about changing the download.gif... but then the icon would be the same for every file, and that's what I am trying to change,

Here on this site, I see that you have setup categories (Add-ons, Geeklog, Themes), and each category has it's own icon at the top of the page. How do you set that icon for the downloads area?

That an alternative for what I am trying to do.


filemgmt how to change icons

Posted on: 04/03/06 07:20am
By: Dirk

When you set up a new category, you can also add an icon. Doesn't work for sub-categories, though and I think there's a bug that won't let you change the icon later (unless you change it directly in the database).

bye, Dirk

filemgmt how to change icons

Posted on: 04/03/06 08:34am
By: donm1021

Dirk - I set up the categories and added an icon - however, the icons don't appear? I viewed the source for the page and the icons are there... but they don't appear? very strange.

I just checked again and I am using the Contemporary_v1 theme... using this theme the icons don;t appear at all. However I switched to the professional theme and the icons appear to be broken images?

Is it a permissions (CHMOD) issue? I looked and the icon images are in the filemgmt_data/category_snaps/ directory

(**Note - Maybe this will help anyone else that runs into this - I changed the configuration of the filemanager category thumbnails directory to filemgmt/images and the images began to work fine. It appears that anything that is put into the category_snaps directory doesn't get read? Bug?)

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=64496