Subject: PHPLinks plugin on GL 1.3.11r3

Posted on: 11/02/06 03:44pm
By: jalmada

I have been testing the PHPLinks plugin integration on my test GL system - virgin 1.3.11r3 install.

I noted problems with kses.class settings in lib-common.php and fixed those, since the issued version of the lib-common.php has out-of-date settings and finally managed to get the plugin to come up without error.

Trouble is, now categories will not add at all. In fact, it appears that the plugin just does not seem to allow entry of any new settings or configuration data from the admin panels in the phplinks admin area.

The weird part of all of this is that I get no error messages at all in my error log and the categories or changes I add apparently "take" without error when I submit them. In fact, categories report as "added" but then when I go look, no such entry has occurred. I use SQLYog for my MySQL table maintenance and no entries are making it into the tables there, so I know this has to be some sort of SQL posting problem, probably endemic to the replaced GL files that the plugin provides.

I've triple checked my config files just to be safe - I'm a long-time GL user and am used to the strange things that happen in GL sites, but this one has me stumped for now.

Anyone with advice to give would surely find appreciation from me as to what the cause of this problem might be.

Thanks!

PHPLinks plugin on GL 1.3.11r3

Posted on: 11/02/06 03:54pm
By: Dirk

Just a wild guess: register_globals = off?

bye, Dirk

PHPLinks plugin on GL 1.3.11r3

Posted on: 11/02/06 04:05pm
By: jalmada

LOL - Nope - double-checked that too:

"; You should do your best to write your scripts so that they do not require
; register_globals to be on; Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
register_globals = On"

PHPLinks plugin on GL 1.3.11r3 - updates require for 1.4.0...?

Posted on: 03/10/06 07:36pm
By: Anonymous

Was this ever resolved? Has anyone updated PHPlinks for 1.4.0sr5-1?

I have tried following the instructions to integrate the phplinks version developed for .11 with this version of GL but it came up with the error, "Parse error: syntax error, unexpected T_DNUMBER in /home/account/public_html/lib-common.php on line 2922" - as I have no programming knowledge, this means nothing to me (could be a minor typo issue or major).

Any ideas gratefully received.

Many thanks

A

Re: PHPLinks plugin on GL 1.3.11r3

Posted on: 18/12/06 06:41pm
By: Anonymous

i have just tried to edit something on file include/add.php and got this error
Parse error: syntax error, unexpected T_DNUMBER
cannot find what the problem can be and am waiting for help from dew-code maybe you could try there if your stuck
http://www.dew-code.com/modules/newbb/viewforum.php?forum=10

Re: PHPLinks plugin on GL 1.4.1

Posted on: 02/03/07 11:27am
By: Anonymous

Has anyone updated the PhpLinks plug in and got it to work with GL 1.4.1 please? If so, please could you direct me to the plug in download (Squatty's site is completely off with a MySQL error now).

Many thanks

Anonymous

Re: PHPLinks plugin on GL 1.3.11r3

Posted on: 08/03/07 10:29am
By: Laugh

What do you use PHPLinks mainly for? Link Exchanges?

Re: PHPLinks plugin on GL 1.3.11r3

Posted on: 09/03/07 04:28pm
By: Anonymous

I have hierarchical directories running on my sites (one nearly 2000 links) - I found the phpLinks plug in to be very useful as it also allowed multiple categories, tracking links in/out, flags (to highlight geographic location), and I forgot what else - but it convinced me it was the solution for my requirements!

I see that phpLinks is now being updated as Dew-phpLinks, but has anyone come up with a solution for running either (integrated) with GL 1.4.1?

Many thanks

Anonymous

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=63616