Subject: install Upgrade of 1.3.11.sr2

Posted on: 10/10/05 01:22pm
By: jollymoon

Installed the upgrade last night from 1.3.11sr1 to 1.3.11sr2.

Now I cannot edit my StaticPages...error error....

URL Class: number of names passed to setArgNames must be equal or greater than number of arguments found in URL

I tried to copy the functions.inc (the only file in the upgrade that has a file in Plugins/Staticpages) from 1.3.11sr1 OVER the one supplied in 1.3.11.sr2 (leaving everything else the same), but that didn't work. Must be somewhere else?

Everything else seems to work fine.

What did I do wrong....

thanx

install Upgrade of 1.3.11.sr2

Posted on: 11/10/05 06:52pm
By: derekhed

First off, I'll admit that I broke rule #1: I proceeded to upgrade before backing up my working installation!

I used the 1.3.11sr2 upgrade package and copied everything over to my server after testing the stuff on my laptop. My site now gives me a big, white page. Nada.

My question is: can I turn on any kind of logging or is there any way to find out where the site is damaged? I can set the site_enabled flag to false and see my site_disabled_msg. When I try and turn the site back on, I get nothing.

Any advice is welcome, harassment is expected!

install Upgrade of 1.3.11.sr2

Posted on: 11/10/05 08:08pm
By: mevans

jollymoon,

I found the same problem. I believe it was the fix listed in the CHANGELOG as:

Fixed bug with topic-specific blocks not showing up on the article page when
URL rewriting was enabled (bug #401) [Dirk]

I temporarily fixed the problem by commenting out the change in lib-common.php around line 806 in function COM_siteHeader()...

        if( empty( $sid ) && $_CONF['url_rewrite'] )
        {
            COM_setArgNames( array( 'story' ));
            $sid = COM_applyFilter( COM_getArgument( 'story' ));
        }



By commenting these lines out, you can now edit your StaticPages.

I haven't had time to actually determine why this is a problem yet and hope to spend a little time this evening trying to figure it out so I can get both the staticpage edit working and the problem solved that this code was originally trying to fix.


install Upgrade of 1.3.11.sr2

Posted on: 12/10/05 12:44am
By: jollymoon

That was deeper into the Rabbit hole than I wanted to go, but thanx Neo, live long and prosper!

not worthy

install Upgrade of 1.3.11.sr2

Posted on: 12/10/05 04:59am
By: Anonymous

I had the same problem after upgrading but this post resolved
it (http://www.geeklog.net/forum/viewtopic.php?showtopic=48726)...
turn url-rewrite off and on

Frank

install Upgrade of 1.3.11.sr2

Posted on: 12/10/05 06:59am
By: mevans

I had the same problem after upgrading but this post resolved
it (http://www.geeklog.net/forum/viewtopic.php?showtopic=48726)...
turn url-rewrite off and on


Frank,

From reading the post you referenced, it appears that the fix was turning off the rewrite functionality. Unfortunately, that isn't an option for me, I have too many search engines that have already indexed my site with it on. Did you turn rewrite back on and it works now?

The only way I could get the rewrite code to work consistently was to comment out the lines referenced above in lib-common.php.

Mark

install Upgrade of 1.3.11.sr2

Posted on: 12/10/05 07:10am
By: Anonymous

I checked it once with turning off and on and it was working.
But now it is not working either, only when url-rewrite is turned off...

I am using url-rewrite as well and would like to have it back.

Frank

install Upgrade of 1.3.11.sr2

Posted on: 12/10/05 03:19pm
By: Dirk

For those having problems editing static pages when URL rewriting is on, try this patch.

Haven't had a chance to look into the issue with that new piece of code in lib-common.php (as quoted above). If it's causing you problems, comment it out. The only consequence will be that blocks set to be displayed in a specific topic won't show up.

bye, Dirk

install Upgrade of 1.3.11.sr2

Posted on: 12/10/05 05:43pm
By: geKow

commenting these four lines out in lib-common, gives me another problem. Now trying to edit a static page leads me directly to the staticpages index page, no chance to edit

geKow

correction: this happens if you apply dirks patch AND outcomment the four lines. Without the patch it seems to work.

install Upgrade of 1.3.11.sr2

Posted on: 13/10/05 05:05am
By: Anonymous

I experienced the same, the patch didn't solve the url-rewrite issue and commenting out brings only the static page editor up and keeps it there.

the old index and commenting out works.

Frank

install Upgrade of 1.3.11.sr2

Posted on: 23/10/05 04:16am
By: Dirk

Could people suffering from this problem please try out Vinny's suggestion from the bugtracker and give us some feedback, please?

bye, Dirk

install Upgrade of 1.3.11.sr2

Posted on: 29/10/05 08:01am
By: Dirk

Okay, another attempt to fix this issue:

Starting with an unmodified 1.3.11sr2 install (i.e. ignoring all the patches listed above), download a new admin/plugins/staticpages/index.php and a new staticpages/index.php.

Does that work?

bye, Dirk

install Upgrade of 1.3.11.sr2

Posted on: 30/10/05 09:25am
By: LWC

I am pleased to report that I used only your new "admin.../index.php" (why would I even need the other one?) and it has solved the problem!

install Upgrade of 1.3.11.sr2

Posted on: 30/10/05 09:37am
By: Dirk

[QUOTE BY= LWC] (why would I even need the other one?)[/QUOTE]
Static pages have an "edit" link at the bottom (if you're a static pages admin). That one would still use a "rewritten" URL and won't work then.

bye, Dirk

install Upgrade of 1.3.11.sr2

Posted on: 06/11/05 11:31am
By: LWC

You're right - and that index.php solved the problem too for me.

Did you update sr2's full and upgrade archives?

install Upgrade of 1.3.11.sr2

Posted on: 01/12/05 09:38am
By: surgeon

Dirk links above won`t work anymore. Where i can find correct static index.php`s?

install Upgrade of 1.3.11.sr2

Posted on: 01/12/05 03:10pm
By: Dirk

Sorry, both the CVS web frontend and the project site are currently down, so the above URLs don't work at the moment.

We will be releasing a bugfix update for 1.3.11sr2 eventually - give us some more time, please.

In the meantime, you can work around the problem by (temporarily) disabling url_rewrite in config.php

bye, Dirk

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=58612