Subject: Could not find config.php (GL on Plesk)

Posted on: 18/07/05 01:47pm
By: ppmnt

I am trying to set up a new Geeklog site on a server with virtual hosts which are administered by Plesk. It turns out Plesk is incredibly sensitive to things like uid's and gid's and any inode changes and who knows what else. The issue I'm running into is kind of puzzling though:

Here's my setup:

/home/httpd/vhosts/domain.com (home directory)
/home/httpd/vhosts/domain.com/geeklog 
/home/httpd/vhosts/domain.com/httpdocs




~/geeklog is where all the geeklog files are, like the config.php or the system subdirectory.
~/httpdocs is the document_root of the domain, so it's basically the "public_html"

So my config.php looks like this:

$_CONF['path']        = '/home/httpd/vhosts/domain.com/geeklog/';
$_CONF['path_html']   = '/home/httpd/vhosts/domain.com/httpdocs/';




So... everything looks good so far? When I go to http://www.domain.com/admin/install/install.php and enter the path to the config.php I get this:


Geeklog Installation - Error

Geeklog could not find config.php in the path you just entered: /home/httpd/vhosts/domain.com/geeklog
Please check this path and try again. Remember that you should be using absolute
paths, starting at the root of your file system.


I've tried entering these 3 paths:
/home/httpd/vhosts/domain.com/geeklog
/home/httpd/vhosts/domain.com/geeklog/
/home/httpd/vhosts/domain.com/geeklog/config.php




And get the same thing every time. I just don't understand why it would not be able to find the conig.php. I thought it might be a permissions issue, but all directories are 755 (with config.php being 644). I've tried trouble-shooting this but it just doesn't make any sense, so I'm wondering if Plesk has something to do with this.

Does anybody have any ideas? Has anybody used Geeklog on Plesk before? Or run into this before, knowing you are giving the right path?


Could not find config.php (GL on Plesk)

Posted on: 18/07/05 05:34pm
By: ppmnt

I think I figured out the issue. I used phpinfo to compare the PHP configuration on my existing server and this new server, and found that on the new server open_basedir is set to:

/home/httpd/vhosts/domain.com/httpdocs:/tmp

which means that my directory /home/httpd/vhosts/domain.com/geeklog is not included. It seems that if you use Plesk to create a new vhost by default it sets open_basedir to the document_root and /tmp. If a directory is not listed in open_basedir files in that directory can't be accessed by PHP, even with an include or require statement. This finally explains why it couldn't find config.php (and means I'm not going crazy after all).

I've asked the server admin to change this setting, and hopefully I'll be up and running soon!

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=55579