Subject: need galleryblock guru

Posted on: 13/05/04 08:00pm
By: Anonymous

Warning: galleryblock(init.php): failed to open stream: No such file or directory in /var/www/localhost/htdocs/blocks/galleryblock/phpblock.php on line 20

Fatal error: galleryblock(): Failed opening required 'init.php' (include_path='/var/www/localhost/htdocs/system/pear/:.:/usr/local/lib/php') in /var/www/localhost/htdocs/blocks/galleryblock/phpblock.php on line 20

annyone can help me? thanks

need galleryblock guru

Posted on: 14/05/04 12:50am
By: destr0yr

Make sure you have the following set in your /path/to/geeklog/system/lib-custom.php, function phpblock_galleryRandomPhoto
$GALLERY_BASEDIR = "/path/to/geeklog/public_html/gallery/";
define(CACHE_FILE, "/path/to/geeklog/public_html/gallery/block-random.cache");



need galleryblock guru

Posted on: 14/05/04 06:54am
By: Anonymous

hi dest, and thanks for your answer...
is strange, everything to change in lib-custom.php function phpblock_GalleryBlock() my error is ever;
Warning: galleryblock(init.php): failed to open stream: No such file or directory in /var/www/localhost/htdocs/blocks/galleryblock/phpblock.php on line 20

Fatal error: galleryblock(): Failed opening required 'init.php' (include_path='/var/www/localhost/htdocs/system/pear/:.:/usr/local/lib/php') in /var/www/localhost/htdocs/blocks/galleryblock/phpblock.php on line 20

maybe this error mot is in lib-custom.php

dest, my english in not good maybe i don`t understand, can you post lib-common.php with galleryblock ionstalled?

thanks

need galleryblock guru

Posted on: 14/05/04 08:29am
By: destr0yr

Make sure you're using this copy of the random photo block.
http://www.squatty.com/filemgmt/singlefile.php?lid=225


need galleryblock guru

Posted on: 14/05/04 10:12am
By: Anonymous

opss but galleryblock 1.1.1 not good?
ok i test galleryRandomPhoto, have the same feature?

thanks

need galleryblock guru

Posted on: 14/05/04 12:30pm
By: Anonymous

i`ve tested galleryRandomPhoto and work, but i need also galleryblock(another different block):
Warning: galleryblock(init.php): failed to open stream: No such file or directory in /var/www/localhost/htdocs/blocks/galleryblock/phpblock.php on line 20

Fatal error: galleryblock(): Failed opening required 'init.php' (include_path='/var/www/localhost/htdocs/system/pear/:.:/usr/local/lib/php') in /var/www/localhost/htdocs/blocks/galleryblock/phpblock.php on line 20

anyone can help me?

thanks

need galleryblock guru

Posted on: 16/03/05 01:25am
By: TeMpTiN

Good morning all,

I to would like to use both the gallery block and the gallery random photo block on the homepage however in my case when the random photo block is enabled (homepage only) the gallery block does not show on the home page. the gallery block works fine on other pages. when i disable the random photo block to try to get the gallery block to show on the home page i get the error listed above.

any input is away great
thanks gang.

need galleryblock guru

Posted on: 16/03/05 01:41am
By: asmaloney


I don't use the random photo one, but I imagine what's going on is we're both including gallery's init.php, which is probably a Bad Thing. It's likely the same thing that doesn't allow you to show the gallery block alongside your gallery.

I intend to add random photo functionality to the Gallery Block when I get some time [soon-ish Shocked ] and I'll look into this a bit more. Gallery has gone through some changes since I made the first version. Right now I'm more interested in cleaning up/improving the stats plugin though...

- Andy

need galleryblock guru

Posted on: 16/03/05 03:38am
By: TeMpTiN

Thanks boss!

If I get the urge I may try something a little dirty since I know very little about php and try to combine the blocks. Ill let you know it works or goes horribly wrong. Ether way it will be a learning experience.

need galleryblock guru

Posted on: 21/03/05 10:36am
By: Centauri

I have some trouble with this block too.

I have downloaded the latest 1.1.2 using geeklog 1.3.11 and Gallery v1.4.4-pl4 .

And have placed the block on the right side.
Now by topics i get this error
    Warning: GalleryBlock(init.php) [function.GalleryBlock]: failed to open stream: No such file or directory in /home/contracts/CN20050053/www/blocks/galleryblock/phpblock.php on line 20


    Fatal error: GalleryBlock() [function.require]: Failed opening required 'init.php' (include_path='/home/contracts/CN20050053/www/system/pear/:.:/usr/local/lib/php') in /home/contracts/CN20050053/www/blocks/galleryblock/phpblock.php on line 20



By geekbook i get this, but the block shows.
Warning: Cannot modify header information - headers already sent by (output started at /home/contracts/CN20050053/www/klaagmuur/index.php:25) in /home/contracts/CN20050053/www/gallery/lib/lang.php on line 342



And it works perfectly without error by the staticpages.

need galleryblock guru

Posted on: 21/03/05 01:16pm
By: asmaloney

[QUOTE BY= Centauri]
Now by topics i get this error
    Warning: GalleryBlock(init.php) [function.GalleryBlock]: failed to open stream: No such file or directory in /home/contracts/CN20050053/www/blocks/galleryblock/phpblock.php on line 20


    Fatal error: GalleryBlock() [function.require]: Failed opening required 'init.php' (include_path='/home/contracts/CN20050053/www/system/pear/:.:/usr/local/lib/php') in /home/contracts/CN20050053/www/blocks/galleryblock/phpblock.php on line 20




By geekbook i get this, but the block shows.
...
And it works perfectly without error by the staticpages.[/QUOTE]

I'm not sure what you mean by 'by topics', 'By geekbook', and 'by the staticpages', but anyway. The first error looks like either $GALLERY_BASEDIR is not defined [make sure it ends in '/'] in the config.php file or the file $GALLERY_BASEDIR/init.php is not accessible.

I don't know about the geekbook thing - I don't know what geekbook is.

- Andy

need galleryblock guru

Posted on: 21/03/05 07:12pm
By: Centauri

Well i have solved it some other way.

In phpblock.php the require_once config.php and init.php i have put the path in front of it like this.
require_once( '/home/contracts/CN2004/www/gallery/init.php' );

Fot config the same.

For the update.gif i did this
$GB_CONF['lu_image_path'] = '{site_url}/galleryblock/update.gif';


So now that is also working on every page.


With topics i refer to what on this page is Sections. It's the main blogging feature of geeklog.
As you can see in the url http://www.geeklog.net/index.php?topic=GeekLog

There is also an staticpage example on this page here

Now there only is still a problem with Geekbook, for an example of that i refer to my site here It's in Dutch

Warning: Cannot modify header information - headers already sent by (output started at /home/contracts/CN20050053/www/klaagmuur/index.php:25) in /home/contracts/CN20050053/www/gallery/lib/lang.php on line 342




I will see about that in the morning

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=34741