Subject: Images in html story

Posted on: 12/04/04 03:44pm
By: Anonymous

Is there a way when I write a story to have html picture links within the text. So if I am copying and pasting a article from a content provider with a link to a picture on their site or filed with them that I it will make the link work, and I wont have to write the picture down in the image spaces below a story.

Thanks

Images in html story

Posted on: 12/04/04 04:00pm
By: Dirk

You have to allow the use of the img tag - see the FAQ for details.

And, of course, you should ask the site you're linking to if that is okay with them, as you are increasing their traffic if you link to their images.

bye, Dirk

Images in html story

Posted on: 12/04/04 06:32pm
By: Anonymous

ya i tried that but it wont work, I have a story that is several paragraphs long and in the middle is a img tag like:

<table cellspacing="1" cellpadding="1" border="1" width="155"> <tr align="center"><td>Streaming Video Preview of</b><br><a href="http://www.eaglevisionusa.com/video/Mole.rm"></a><BR><b>"Celebrity Mole Hawaii"</td></tr></table>

it still wont let this through.

Images in html story

Posted on: 12/04/04 06:44pm
By: racooper

Maybe it's just your cut-and-paste into the forum, but I don't see a single tag in your code sample...I think what you're looking for, however is this, added in your geeklog/config.php file:

//add to $_CONF['user_html'] or $_CONF['admin_html']:

 'img'    => array('src' => 1, 'alt' => 1, 'align' => 1,
                   'border' => 1, 'width' => 1, 'height' => 1),



now, if you're trying to use the href link to an .rm file, you're not going to get an image, no matter how hard you try. an img needs to be (for practical purposes) a .gif, .jpg or .png file.

Images in html story

Posted on: 12/04/04 07:21pm
By: Anonymous

That didnt come through at all can you try it again. I cant get anything to work using an img allow and a a href allow or anything. How could I allow a .rm file or anything like that a .swf for instance?

Images in html story

Posted on: 12/04/04 07:48pm
By: Anonymous

Here is another type of image link i am trying to use.

<P align="left"><table border="1" cellspacing="0" cellpadding="0"><tr align="center"><td>MusicDish Network Sponsor<BR><a href="http://www.xxxxxxxxxyyyyzzz.com"></a></td></tr></table>

Images in html story

Posted on: 12/04/04 07:53pm
By: casper

Try googling after som html help.

Or this site.

Fist i found, have an ok description on tags.

Images in html story

Posted on: 12/04/04 07:58pm
By: Anonymous

Here is a link to a page on my site here

you can see if you look through some of the articles. i dont need html help i just am trying to get full access for posting under the admin. i need to have files that are embedded into html formated stories posted that draw images from other sites and have followed all the FAQ's with no avail. So any help would be awesome.

Images in html story

Posted on: 12/04/04 08:06pm
By: casper

If you are trying to put a image in ie a story, you ned to use the img-tag.

Ie link in the geeklog-logo, do this:

<img src="http://www.geeklog.net/layout/XSilver/images/logo.gif" width="183" height="70" border="0">






And to put a link to that img, do this:

<a href="http://www.geeklog.net"><img src="http://www.geeklog.net/layout/XSilver/images/logo.gif" width="183" height="70" border="0"></a>




EDIT: Assuming you have put those tags in your config.php as suggested prior in this tread.

Images in html story

Posted on: 12/04/04 08:20pm
By: casper

Been looking on your site, here on your link to us page.

Also there you need to include the img-tag so your user can link to your site with those banners you have.

Images in html story

Posted on: 12/04/04 08:31pm
By: samstone

If you use the HTMLArea with ImageManager which is available here. You can copy and past an entire page directly to your story and the photos will be automatically linked.

But, like Dirk said, make sure you have permission to do so.

sam

Images in html story

Posted on: 12/04/04 08:37pm
By: Anonymous

No,

i do have permission i syndicate news from a guy and he said he would cut off my content if the images werent displayed but he also knew it was a scripting issue and is giving me a little room

Thanks guy Ill try that link

i was really in a bind

Images in html story

Posted on: 12/04/04 09:05pm
By: Anonymous

No dice on that although very cool.

Here is what i need.
1. I get emails formatted in html to post on my site from providers. In those html stories are image links like this:

&lt;p align=&quot;center&quot;&gt;&lt;b&gt;Robbie Cooper - The Way Rock Should Be&lt;/b&gt;
&lt;br&gt;By Ben Ohmart, &lt;a href=&quot;http://www.xxxxyyyy.com&quot; target=&quot;_blank&quot;&gt;&lt;IMG SRC=&quot;http://www.musicdish.com/z_md/md_w125.gif&quot; WIDTH=&quot;125&quot; HEIGHT=&quot;20&quot; BORDER=&quot;0&quot;&gt;&lt;/a&gt;

&lt;p align=&quot;center&quot;&gt;&lt;a href=&quot;http://www.cccccc.com/cd/robbiec/from/musicdish&quot; target=&quot;_blank&quot;&gt;&lt;img src=&quot;http://cccc.com/mcccc.network/default.php?img_cl=bandfront.jpg&quot; width=&quot;300&quot; height=&quot;199&quot; hspace=&quot;2&quot; vspace=&quot;2&quot; border=&quot;0&quot;&gt;&lt;/a&gt;

What I need is these image links to show up and they are not there are just boxes shown where the actual images should be.

Is there a way or a setting that i need to turn on or off to allow these to be shown.

I added the img tad to the config.php file and it wouldnt allow the images to be shown.

I also tried everything else that people and FAQ's have suggested also I have over 70 stories with these tags in the stories that just need to be activated for lack of better words.

If anyone has any idea that would be great

Thanks

Images in html story

Posted on: 13/04/04 12:18am
By: racooper

[QUOTE BY= Jeff]
What I need is these image links to show up and they are not there are just boxes shown where the actual images should be.
[/QUOTE]

Just a thought: can you link to the images directly? Do they work if you put the img src in a new, blank (non-GL) page? There is the possibility that the source site could be blocking non-local referrers...Tripod.com is annoying about not allowing remote linking, for example.

Images in html story

Posted on: 13/04/04 07:39am
By: Anonymous

they work perfectly, try the ones posted above, I just dont know what else to do I would think that they would work since i have orking href tags bold tags strong tags etc.

Images in html story

Posted on: 13/04/04 09:48am
By: Turias

After you post, click EDIT. Is the HTML that you see correct? Or was something stripped out?

Images in html story

Posted on: 13/04/04 10:27am
By: Anonymous

The html tags like "a href" and "b" and "stong", "italic" are showing up but there are no images being displayed in the post. The article looks fine minus the images. The tags are present to call the images from the link but they are not showing up also the borderrs which should surround the images and frame them but again no images.

Images in html story

Posted on: 13/04/04 10:33am
By: Turias

Ok, so the actual HTML in the story is identical after you post it?

Images in html story

Posted on: 13/04/04 10:43am
By: Anonymous

Yes correct the html works as far as links etc type style, but there are some instances where the html is stripped from an article or story where dialougue between two people is colored different colors not really what i am too worried about right now. I am more concerned with the images working.

Images in html story

Posted on: 13/04/04 11:00am
By: Turias

Well, I've tried posting the code in a story on my own site and it works perfectly. If the correct source is not stripped out, then it doesn't seem like a Geeklog issue, to me. Can you point to different images on other servers?

Also, it would help if you linked us to a story on your site that is not working.

Images in html story

Posted on: 13/04/04 11:34am
By: Anonymous

Here This is what the article should look like This is on a test page with the html from the an email that I get just loaded into an html file through Dreamweaver.

Here is the link to the same story and same html/code on my page. That doesnt work. here The only thing I edit is grab the first Paragraph for the intro and the headline for the story headline.

it is the same code exactly copied and pasted from the email with the html in it.

Thanks for your help

Jeff

Images in html story

Posted on: 13/04/04 11:47am
By: Turias

Um, you said the img tags are not getting stripped out of your stories. They obviously are (look at the source). If you read this FAQ entry thoroughly, you should be able to configure your site so that this works.

Images in html story

Posted on: 13/04/04 12:11pm
By: Anonymous

I did and I tried it this is from the config file and what I changed and allow for stories in both the admin and the user:

$_CONF['user_html'] = array (
'p' =&gt; array(),
'b' =&gt; array(),
'i' =&gt; array(),
'a' =&gt; array('href' =&gt; 1, 'title' =&gt; 1),
'em' =&gt; array(),
'br' =&gt; array(),
'tt' =&gt; array(),
'hr' =&gt; array(),
'li' =&gt; array(),
'ol' =&gt; array(),
'ul' =&gt; array(),
'code' =&gt; array(),
'pre' =&gt; array()
);

/* This is a list of HTML tags that Admins (site admin and story admins) can
* use in their posts. It will be merged with the above list of user-allowable
* tags ($_CONF['user_html']). You can also add tags that have already been
* listed for the user-allowed HTML, so as to allow admins to use more
* attributes (see 'p' for an example).
*/
$_CONF['admin_html'] = array (
'img' =&gt; array('src' =&gt; 1, 'alt' =&gt; 1, 'width' =&gt; 1),
'p' =&gt; array('class' =&gt; 1, 'id' =&gt; 1, 'align' =&gt; 1),
'div' =&gt; array('class' =&gt; 1, 'id' =&gt; 1),
'span' =&gt; array('class' =&gt; 1, 'id' =&gt; 1),
'table' =&gt; array('class' =&gt; 1, 'id' =&gt; 1, 'width' =&gt; 1, 'border' =&gt; 1,
'cellspacing' =&gt; 1, 'cellpadding' =&gt; 1),
'tr' =&gt; array('class' =&gt; 1, 'id' =&gt; 1, 'align' =&gt; 1, 'valign' =&gt; 1),
'th' =&gt; array('class' =&gt; 1, 'id' =&gt; 1, 'align' =&gt; 1, 'valign' =&gt; 1,
'colspan' =&gt; 1, 'rowspan' =&gt; 1),
'td' =&gt; array('class' =&gt; 1, 'id' =&gt; 1, 'align' =&gt; 1, 'valign' =&gt; 1,
'colspan' =&gt; 1, 'rowspan' =&gt; 1),
'img' =&gt; array('src' =&gt; 1, 'alt' =&gt; 1, 'align' =&gt; 1,
'border' =&gt; 1, 'width' =&gt; 1, 'height' =&gt; 1),

);

Images in html story

Posted on: 13/04/04 12:15pm
By: Turias

You've got an extra comma at the very end there, Jeff.

Images in html story

Posted on: 13/04/04 12:28pm
By: Anonymous

No dice man still doesnt want to work I also saw that I had an extra line on the first entry for admin so I removed that as well.

Images in html story

Posted on: 13/04/04 06:27pm
By: Turias

You must have a syntax problem, somewhere. Is img even listed in the allowed HTML on the story editor page?

The only other thing I can think of is if you upgraded to a newer version of Geeklog but did not update all of the files.

Images in html story

Posted on: 14/04/04 07:23pm
By: Anonymous

Thanks for your help. I somehow made it work by re downloading the GL .tar and copy & pasting the code back into a new config file and it works I dont know what happened maybe somehting was corrupted when i was doing the editing but now it works great. I wouldnt think BBedit would do such a thing but you never know, Thank you again for your patience and help


Jeff

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=33398