Subject: 1146: Table 'geeklog.gl_staticpage' doesn't exist

Posted on: 24/09/02 03:23pm
By: WAW401

I just upgraded to 1.3.6, and now that all built-in features have authentication requirements, I installed Phill's (GDev) static pages to get the version that's privilege aware. After fighting with upgrading then uninstalling/reinstalling the plug-in, I now get the following error in the center of the main page: 1146: Table 'geeklog.gl_staticpage' doesn't exist I know that table doesn't exist, because after the uninstall/reinstall w/ Phil's version the GL database has a "staticpage" table instead of the "gl_staticpage" table it used to. please help.

1146: Table 'geeklog.gl_staticpage' doesn't exist

Posted on: 25/09/02 12:44am
By: Dirk

That's an incompatibility between Geeklog 1.3.6 and Phill's plugin. Until Phill fixes this, you could rename the "gl_staticpage" table in your database back to "staticpage". You would also have to change the name of the staticpage table in lib-database.php so that it reads: $_TABLES['staticpage'] = 'staticpage'; bye, Dirk

1146: Table 'geeklog.gl_staticpage' doesn't exist

Posted on: 26/09/02 03:50pm
By: WAW401

Thanks, Dirk. I suspected that GL 1.3.6 was simply looking for the table, so I created an empty one (w/ the same fields as the normal staticpage table just in case). This solved the problem, Phil's staticpage database is used but the homepage no longer complains on the "1146: Table 'geeklog.gl_staticpage' doesn't exist" problem. All built-ins work properly, and Phil's staticpage plugin works perfectly and is privilege aware! I only started using GL at v. 1.3.5 and you guys have (w/ Phil's help) put together an excellent package. Your hard work is greatly appreciated!

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=12610