Subject: Gallery Remote

Posted on: 21/07/02 04:20pm
By: Anonymous

I got Geeklog/Gallery integration working just fine... But now the gallery remote does not work. Anyone know what to edit to get those to work?

Gallery Remote

Posted on: 22/07/02 04:46pm
By: Anonymous

The reason Gallery Remote doesn't work with the Geeklog integration is because it lacks the isCorrectPassword function. Add this to your gallery/classes/geeklog/User.php (before the final bracket): function isCorrectPassword($password) { return (!strcmp(COM_getPassword($this->username), md5($password))); } Then just use your regular Geeklog login.

Gallery Remote

Posted on: 03/08/02 05:44pm
By: hubersan

I'm having no luck with this either... I keep getting Login Incorrect even after adding that function in.. (even though I don't think it needs to be added since the geeklog/User.php extends the default User.php)

Gallery Remote

Posted on: 08/08/02 03:34pm
By: Anonymous

i am having the same problewm as well. i have applied the forementioned patch ans it still won't log in

Gallery Remote

Posted on: 07/09/02 09:38pm
By: Anonymous

Anyone have any luck with this?? same boat here, works great with geeklog, except GR broke Frown

Gallery Remote

Posted on: 10/10/02 09:56am
By: Anonymous

I haven't been able to get it to work entirely yet, but I haven't fixed a few bugs. There still seems to be a bug or two left that may be in Gallery Remote 1.0b8. I've posted to their forums. I used this in place of the one posted above. The file $your_gallery_dir/classes/geeklog/User.php should be changed. function isCorrectPassword($password) { return (!strcmp(COM_getPassword($this->username), $password)); } I've found that $password is already md5 encoded so there is no need to use md5($password). Also, in the function loadByUserName right above it, there is a bug. The select statement "SELECT uid,fullname,email" should be changed to "SELECT username,fullname,email".

Gallery Remote

Posted on: 10/10/02 02:51pm
By: Anonymous

My mistake. The original function was correct with respect to the md5 function. I took it out because I was doing a GET instead of a POST during my tests. Gallery remote uses POST so you must leave it in there. You still need to modify the select statement. I can login, but I can't display any albums on Mac OS X or Windows. I have a feeling it's a bug in beta 8.

Re:Gallery Remote

Posted on: 12/09/03 02:22pm
By: emagin

This may not address your issue.
I could not get GRemote to work at all, security aside.

So I followed this Forum Post and it now works with the GALLERY user/password, which is fine with me.

The link above is buggy for me in IE, so here it is.
http://gallery.menalto.com/index.php?name=PNphpBB2&file=viewtopic&p=31785#31785
If it does not work above, just copy and paste into your browser.

If someone has a definitive, working solution to get Gallery Remote to work with GL security, please let me know!

HERE ARE THE INSTRUCTIONS FROM THE LINK:

1. geeklog install replaces init.php and util.php
2. get the original versions and rename them init2.php and util2.php
3. in gallery_remote2.php, replace the ref to init.php with init2.php -
Code:
require($GALLERY_BASEDIR . \"init2.php\"); 


4. in init2.php, replace the ref to util.php with util2.php
5. in init2.php, add the following
Code:

$GALLERY_EMBEDDED_INSIDE = \"\"; 


after the include config.php

6. This makes remote think that it is not embedded. Therefore the user and password must exist within gallery when not embedded.

This works well for me. Now to get publishXP working when embedded...

Re:Gallery Remote

Posted on: 02/10/03 01:09pm
By: Anonymous

Thankyou - that's solved it for me!

Steve.

Re:Gallery Remote

Posted on: 04/11/03 01:27pm
By: Anonymous

Hi I followed this, but I keep getting an error from gallery remote saying: "Error: Server contacted, but Gallery not found at this URL (http://myurl/gallery/gallery_remote2.php). Why do I get this error?

Re:Gallery Remote

Posted on: 24/12/03 12:59am
By: Anonymous

I di as follows and am still getting the invalid u/p message.

Cant some one post excatly where/how to add the :

Code:
$GALLERY_EMBEDDED_INSIDE = "";

after the include config.php.


Please post the entire code snippet. Thank You very much


Doc


Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=11413