Subject: Geeklog 1.3.2 b1 question

Posted on: 22/02/02 11:15am
By: Anonymous

Hi, I've recently tried installing 1.3.2 beta1, unfortunately, I was unable to get it to work for various reasons. Because I didn't have the time to mess around with things, my plan was to remove the files and install 1.3.1 again which I've used successfully in the past. My problem is that for some reason, everytime I try to delete any of the Geeklog files, I get a permission denied message, stating that an unlink of the files was not possible. I initially thought this might be a permission problem, because the script may have installed the files with owner as the webserver. Unfortunately that's not the case. The files are all owned by my username and group, and although I can chmod them to anything, it's impossible for me to delete. I was wondering if anyone has experienced a similiar issue, or maybe be able to suggest some ways to remove the files. I unfortunately don't have root access on the server, and the admin has dissapeared on a holiday for two weeks. I'd be greatful for anyone's help. Just to state, it only seems to be this beta release of Geeklog that causes problems. Any other realease, and indeed any other software I've tried installing can be moved around and deleted fine. Thanks.

Try to remove files from php

Posted on: 22/02/02 02:09pm
By: Anonymous

Who is the owner of these files? One month ago I made a instalation of another software, the instation script was a php script, and I see all the files and directories was created with apache's "owner" (apache run with nobody/nogroup, and the files's owner was nobody). My solution was made another php script to delete al the files and directories, and then run these script via web. I hope this solve your problem, I hope you can understand me, my english is not so god.

Re: your advice

Posted on: 22/02/02 06:07pm
By: Anonymous

Excellent advice. Thank you so much. Even though the files were owned by myself, and a part of my group, it took a php script executed by the webserver to delete everything and chmod the directory in question. Now that I know how to solve that problem, do you think I should try the new release of Geeklog out?

Geeklog - Forum