Welcome to Geeklog Sunday, December 17 2017 @ 05:00 am EST

Geeklog 1.7.0

  • Contributed by:
  • Views: 6,758
Announcements

Geeklog 1.7.0 is now available for download.

This release adds support for PostgreSQL (in addition to MySQL and MS SQL), developed by Stan Palatnik during the Google Summer of Code 2009. It also adds a re-authentication option in case the CSRF token expires, thus preventing loss of data. For other improvements, please see the list of changes. Of course, it also addresses the latest security issue.

We would also like to thank all those students again who applied for the Google Summer of Code 2010 and submitted patches for Geeklog. Some of them already made it into 1.7.0, the rest is scheduled for inclusion into Geeklog 1.7.1. We will also be looking into adding more of our successful GSoC projects from 2009 into that release.

A word of thanks also goes out to our translators for making Geeklog available in so many different languages. We could use some more help here, though, as some of the translations haven't been updated in a while.

Please note that we raised the minimum requirements slightly for Geeklog 1.7.0: You now need PHP 4.4.0 or later and MySQL 4.0.18 or later to run Geeklog. We will drop support for PHP 4 entirely with Geeklog 1.8.0 later this year.

Note: The Geeklog demo site has since been updated as well (thanks, Michael). So now you can try out Geeklog 1.7.0 before installing it.