Welcome to Geeklog Friday, October 20 2017 @ 05:02 am EDT

Geeklog 1.8.0

  • Contributed by:
  • Views: 6,254
Announcements

Geeklog 1.8.0 is now available for download.

With Geeklog 1.8.0 we have raised the minimum system requirement for PHP. PHP version 5.2.0 or greater is now required.

There are a number of new features with this version of Geeklog. These include:

  • Improved Configuration, which was the Google Summer of Code project of Akeda Bagus from 2010. Improvements include the ability to search for configuration attributes, tabs, input validation as well as an updated look.
  • OAuth Support, allowing users to log into a Geeklog site with their Facebook, Twitter, or LinkedIn account, developed by Hiroshi Sakuramoto of Geeklog Japan.
  • Includes jQuery 1.5.2 and jQuery UI 1.8.11
  • Updated Professional theme with new icons and tooltips.
  • Reworked Plugin Admin interface that now checks for dependencies when a plugin is installed.

Please note: In our beta version and release candidates for Geeklog 1.8.0 a number of Geeklog paths were disclosed as variables in JavaScript. It is highly recommended to upgrade any of your sites using these versions to the final version of Geeklog 1.8.0.

Developers, please read more below to find out what has changed or is new in Geeklog that may affect development of themes and plugins.

Here is a list of features that plugin and theme authors may be interested in incorporating into your work. The core plugins have been updated to use these new features so they make excellent code examples.

  • jQuery and jQuery UI can now be set and used by themes and plugins through Geeklogs new Scripts class. The Scripts class also allows you to set additional JavaScript files and variables along with any css files. For more information on this please read the Wiki.
  • COM_getNoScript is a new function that standardizes the way pages display any JavaScript recommend or required messages.
  • Geeklog now has a standard set of tooltips which can be retrieve by calling COM_getTooltip. There are 4 types Classic, Critical, Help, Information and Warning. There are also extra theme files associated with these tooltips.
  • Plugins can now set code in the footer by using plugin_getfootercode_foo.
  • Autotags now can have usage permissions and descriptions. All core plugins usage permissions for autotags are set in the Geeklog configuration. The descriptions are used in editors that display "Allowed HTML". Check any of the Core plugins autotag function (i.e. plugin_autotags_polls) for an example on how to implement this functionality. To support this functionality Plugin authors will also have to remove any autotags from user input that the user does not have usage rights to. This can be done with one line by using the PLG_replaceTags function and setting the last variable to true ($usercontent= PLG_replaceTags($usercontent, '', true);).
  • Geeklog and the core plugins also set their template files now with COM_newTemplate. This is a wrapper function for the template class and it will automatically set the 4 most common template variables (xhtml, site_url, site_admin_url, layout_url). This function also allows for a drop-in replacement template engine if available. It is recommended that all plugin authors use this function when using the Geeklog template class.
  • To enable version dependencies for your plugin, for other plugins and databases you will have to add in a $requires array to your plugins autoinstall.php file.