Welcome to Geeklog Sunday, October 22 2017 @ 01:24 pm EDT

DokuWiki Integration to geeklog CMS

  • Contributed by:
  • Views: 7,380
Plugins

Dokuwiki plugin 1.5.2 is available.

DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at creating documentation of any kind. It is targeted at developer teams, workgroups and small companies. It has a simple but powerful syntax which makes sure the datafiles remain readable outside the Wiki and eases the creation of structured texts. All data is stored in plain text files – no database is required.

The DokuWiki Integration Plugin for geeklog provides an integration with your geeklog v1.4.1 and higher website. This plugin is based on DokuWiki 2008-05-05, with a new transparent theme to suit light and dark color scheme.

System Requirements

DokuWiki has the following system requirements:

* PHP 4.3.3 and higher. Because of some security issues PHP 4.3.10 or higher is strictly recommended. (PHP5 should be fine.)

* PHP's GD extension for use with libGD 2 (a graphics library) is recommended but not needed

* DokuWiki should work in PHP's Safe Mode, depending on your hosters configuration you may need to use the safemodehack option

* DokuWiki is designed to run with PHP's Option register_globals set to off.

* DokuWiki requires that your site be configured with UTF-8 encoding. If you site is not already setup for UTF-8, you may want to consider converting. Installing DokuWiki on a non-UTF-8 site will work, but some characters may get corrupted.