The first beta version of Geeklog 1.8.0 is now available for download. As announced, this version now requires PHP 5.2.0 or later.

New feature in this version include:

... as well as a lot of other improvements, e.g. new icons, tweaks in the user interface, and the inclusion of jQuery.

We would like to encourage you to download this beta version, try it out, and give us your feedback. Since this is a beta version, it may still contain bugs, so you may want to wait before actually running it on a "live" site. We will keep rolling out updates over the next weeks, though, and still plan to ship the final version later this month.

Comments (1)