Contributed by: Dirk Sunday, January 02 2011 @ 12:31 pm EST
Starting with Geeklog 1.8.0, Geeklog will require PHP 5.2.0 or later to run. The last version of Geeklog to run on older PHP versions will be 1.7.2, to be released in early 2011.
To put things into perspective: Support for PHP 4 by the PHP development team offically ended on December 31, 2007. A last official release, PHP 4.4.9, was made on August 8, 2008. Since then, no security or other bugfixes have been released for PHP 4.
Some Linux distributions with long-term support, most notably Red Hat Enterprise Linux 4 (RHEL 4) and CentOS 4, shipped with PHP 4 at the time they were released and have therefore committed to continue PHP 4 support until the end of their support period. Therefore, unfortunately, there are still "supported" PHP 4 installations out there.
As a compromise and service to those of our users being "stuck" on such a setup, the Geeklog Team will continue to provide security fixes for the Geeklog 1.7 branch in a timely manner until February 29, 2012 (which coincides with the "End of Production 3 phase" for RHEL 4). Where by "timely", we mean "as soon as possible, but not necessarily on the same day as the then-current release". The further versions drift apart, the more work will it be for us to backport fixes.
Overall, however, we would really suggest that you switch to a host running PHP 5.2 or later, if at all possible and as soon as possible.
A note about PHP 4.3: Geeklog 1.7.x requires PHP 4.4.0 to be installed. This requirement, however, really comes from the PEAR packages that we ship with Geeklog, not from Geeklog itself. So if you need to run Geeklog 1.7.x on PHP 4.3, you could:
SUPPORTED_PHP_VERin lib-install.php to
Geeklog 1.7.2 will be released some time in the first quarter of 2011. It will be a bugfix release, addressing a compatibility issue with PHP 4[*1] and form the basis for the above-mentioned continued support for security updates until 2012.
Geeklog 1.8.0 was originally scheduled to be released last November. We obviously missed that date and have now rescheduled it for a release in April 2011. As mentioned above, you will no longer be able to install this version on a server that only runs PHP 4.